Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun error
From: Elken, Tom (tom.elken_at_[hidden])
Date: 2013-05-09 13:59:37


> It looks like your PATH is pointing to the Intel MPI mpirun,
> not to the Open MPI mpirun/mpiexec.
[Tom]
Just to expand a little on this, it looks like your path is pointing to the Intel MPI run-time version (mpirt) that is included with the Intel Compiler and it's PATH/LD_LIBRARY_PATH is set up by compilervars.[c]sh.
A common way to set up OpenMPI variables, is by using OFED is mpi-selector.

The combination of the above two runs into this problem:
> >> /opt/intel/composer_xe_2013.1.117/mpirt/bin/intel64/mpirun:
is in the PATH before Open MPI's mpirun.

 
> Check the OpenMPI FAQ:
> http://www.open-mpi.org/faq/?category=running#run-prereqs
[Tom]
Good FAQ. One solution it points to is the use of the --prefix option, or
"note that specifying the absolute pathname to mpirun is equivalent to using the --prefix argument. For example, the following is equivalent to the above command line that uses --prefix:

shell$ /opt/openmpi-1.6.4/bin/mpirun -np 4 a.out"

Another method is to use OpenMPI's mpivars.sh or set the OpenMPI parts of your PATH/LD_LIBRARY_PATH in your shell's startup file AFTER you use the Intel Compiler's compilervars.sh.

-Tom

>
>
> I hope this helps,
> Gus Correa
>
> http://www.open-mpi.org/mailman/listinfo.cgi/users