Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] /usr/bin/ld: skipping incompatible ......
From: Matteo Parsani (parsani.matteo_at_[hidden])
Date: 2013-05-08 15:12:55


Dear All,
I have recently installed gcc 4.7.3 on my cent OS 6.4. Moreover, I have
compiled openmpi 1.6.4 with the above compiler.

My LD_LIBRARY_PATH is set correctly and it points to both /lib and /lib64
where libgfortran.so and libgcc_s.so for 32 and 64 bits are located.

Every time I compile a Fortran, a C or a C++ source code with the wrapper
mpif90, mpicc or mpicx I get this warning:

/usr/bin/ld: skipping incompatible /scratch/home0/pmatteo
/research/lib_install/lib/libgfortran.so when searching for -lgfortran

or

/usr/bin/ld: skipping incompatible /scratch/home0/pmatteo
/research/lib_install/lib/libgcc_s.so when searching for -lgcc_s

I have switch my LD_LIBRARY_PATH as suggested in this thread:
http://www.open-mpi.org/community/lists/users/2009/02/8067.php

but nothing change.

Any idea what I am doing wrong?

I know that it is just a warning but I would like to avoid it.

Thank you.

-- 
Matteo