Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Help diagnosing problem: not being able to run MPI code across computers
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-05-07 12:12:34


The FAQ assumes you realize that CIDR notation requires a value for the "x"... :-)

On May 7, 2013, at 9:04 AM, Angel de Vicente <angelv_at_[hidden]> wrote:

> Hi,
>
> "Jeff Squyres (jsquyres)" <jsquyres_at_[hidden]> writes:
>> The list of names in the hostfile specifies the servers that will be used, not the network interfaces. Have a look at the TCP portion of the FAQ:
>>
>> http://www.open-mpi.org/faq/?category=tcp
>
> Thanks a lot for this.
>
> Now it works OK if I run it like
>
> [angelv_at_comer RTI2D.Parallel]$ mpiexec -loadbalance --mca
> btl_tcp_if_include p1p1 -prefix $OMPI_PREFIX -hostfile $MPI_HOSTS -n 4
> ../../../mancha2D_mpi_h5fc.x\
> mancha.trol
>
> But, the FAQ seems to be wrong, since it also says that I should be able
> to run like:
>
> [angelv_at_comer RTI2D.Parallel]$ mpiexec -loadbalance --mca
> btl_tcp_if_include 192.168.1.x/24 -prefix $OMPI_PREFIX -hostfile
> $MPI_HOSTS -n 4 ../../../mancha2D_\
> mpi_h5fc.x mancha.trol
>
> but then I get the following error:
>
> --------------------------------------------------------------------------
> WARNING: An invalid value was given for btl_tcp_if_include. This
> value will be ignored.
>
> Local host: catar
> Value: 192.168.1.x/24
> Message: Invalid specification (inet_pton() failed)
> --------------------------------------------------------------------------
>
> If I specify the subnet as 192.168.1.0/24 all is in order.
>
> I'm running 1.6.4:
>
> [angelv_at_comer RTI2D.Parallel]$ ompi_info
> Package: Open MPI angelv_at_comer Distribution
> Open MPI: 1.6.4
>
>
> Thanks,
> --
> Ángel de Vicente
> http://angel-de-vicente.blogspot.com/
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users