Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun error
From: Pradeep Jha (pradeep_at_[hidden])
Date: 2013-04-09 23:47:14


Hello,

thanks for the responses. But I have no idea how to do that. Which
environment variables should I look at? How do I find out where is the
openMPI installed and make the mpif90 use the openMPI?

Thanks,
Pradeep

2013/4/2 Elken, Tom <tom.elken_at_[hidden]>

> > The Intel Fortran 2013 compiler comes with support for Intel's MPI
> runtime and
> > you are getting that instead of OpenMPI. You need to fix your path for
> all the
> > shells you use.
> [Tom]
> Agree with Michael, but thought I would note something additional.
> If you are using OFED's mpi-selector to select Open MPI, it will set up
> the path to Open MPI before a startup script like .bashrc gets processed.
> So if you source the Intel Compiler's compilervars.sh, you will get
> Intel's mpirt in your path before the OpenMPI's bin directory.
>
> One workaround is to source the following _after_ you source the Intel
> Compiler's compilervars.sh in your start-up scripts:
> . /var/mpi-selector/data/openmpi_...sh
>
> -Tom
>
> >
> > On Apr 1, 2013, at 5:12 AM, Pradeep Jha wrote:
> >
> > > /opt/intel/composer_xe_2013.1.117/mpirt/bin/intel64/mpirun: line 96:
> > /opt/intel/composer_xe_2013.1.117/mpirt/bin/intel64/mpivars.sh: No such
> file
> > or directory
> >
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>