Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi-1.7 failed to build on Centos 6.4
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-04-04 15:26:52


Fix is coming - it is the --without-memory-manager option (which is the same thing as --with-memory-manager=no) that is breaking it.

On Apr 4, 2013, at 12:19 PM, Limin Gu <lgu_at_[hidden]> wrote:

> Hi all,
>
> I downloaded openmpi-1.7, but it failed to build on Centos 6.4 with following error:
>
> make[10]: Entering directory `/root/openmpi/openmpi-1.7/ompi/contrib/vt/vt/extlib/otf/tools/otfmerge/mpi'
> CC otfmerge_mpi-handler.o
> CC otfmerge_mpi-otfmerge.o
> CCLD otfmerge-mpi
> /root/openmpi/openmpi-1.7/ompi/contrib/vt/vt/../../../.libs/libmpi.so: undefined reference to `opal_memory_linux_malloc_init_hook'
> collect2: ld returned 1 exit status
> make[10]: *** [otfmerge-mpi] Error 1
>
>
> And this is my configure options:
>
> ./configure --with-udapl --with-tm --with-openib --disable-dlopen --without-slurm --without-mx --without-lsf --without-loadleveler --without-memory-manager --with-memory-manager=no --with-psm CC=gcc CXX=g++ F77=gfortran FC=gfortran
>
> Thank you!
>
> Limin
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users