Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] 32-/64-bit library problem in openmpi-1.7rc8r28176 and openmpi-1.9r28175
From: Matthias Jurenz (matthias.jurenz_at_[hidden])
Date: 2013-03-27 06:44:36


Hi Siegmar,

the problem is that FCFLAGS is not passed to the Fortran compiler. Fixed in
revision 28228.

Thanks for the hint!

Kind regards,
Matthias

On Mar 21, 2013, at 9:29 AM, Siegmar Gross <Siegmar.Gross_at_informatik.hs-
fulda.de> wrote:

> Hi
>
> today I tried to build openmpi-1.7rc8r28176 and openmpi-1.9r28175
> on "Solaris 10, x86_64" and "Solaris 10, sparc" with "Sun C 5.12".
> I used the following commands for openmpi-1.7.x and similar commands
> for the other package:
>
> ../openmpi-1.7rc8r28176/configure --prefix=/usr/local/openmpi-1.7_64_cc \
> --libdir=/usr/local/openmpi-1.7_64_cc/lib64 \
> --with-jdk-bindir=/usr/local/jdk1.7.0_07/bin/amd64 \
> --with-jdk-headers=/usr/local/jdk1.7.0_07/include \
> JAVA_HOME=/usr/local/jdk1.7.0_07 \
> LDFLAGS="-m64" \
> CC="cc" CXX="CC" FC="f95" \
> CFLAGS="-m64" CXXFLAGS="-m64 -library=stlport4" FCFLAGS="-m64" \
> CPP="cpp" CXXCPP="cpp" \
> CPPFLAGS="" CXXCPPFLAGS="" \
> --enable-cxx-exceptions \
> --enable-mpi-java \
> --enable-heterogeneous \
> --enable-opal-multi-threads \
> --enable-mpi-thread-multiple \
> --with-threads=posix \
> --with-hwloc=internal \
> --without-verbs \
> --without-udapl \
> --with-wrapper-cflags=-m64 \
> --enable-debug \
> |& tee log.configure.$SYSTEM_ENV.$MACHINE_ENV.64_cc
> make |& tee log.make.$SYSTEM_ENV.$MACHINE_ENV.64_cc
>
>
> "make" breaks with the following error for both packages on both
> platforms:
>
> tyr openmpi-1.9-SunOS.sparc.64_cc 30 tail -15 log.make.SunOS.sparc.64_cc
> F77 libvt_fmpi_la-vt_fmpiconst_2.lo
> F77LD libvt-fmpi.la
> ld: fatal: file .libs/libvt_fmpi_la-vt_fmpiconst_1.o:
> wrong ELF class: ELFCLASS32
> ld: fatal: file processing errors. No output written to
> .libs/libvt-fmpi.so.0.0.0
> make[5]: *** [libvt-fmpi.la] Error 2
> make[5]: Leaving directory `.../ompi/contrib/vt/vt/vtlib'
> make[4]: *** [all-recursive] Error 1
> make[4]: Leaving directory `.../ompi/contrib/vt/vt'
> make[3]: *** [all] Error 2
> make[3]: Leaving directory `.../ompi/contrib/vt/vt'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `.../ompi/contrib/vt'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/.../ompi'
> make: *** [all-recursive] Error 1
> tyr openmpi-1.9-SunOS.sparc.64_cc 31
>
>
> tyr vtlib 39 pwd
> .../ompi/contrib/vt/vt/vtlib
> tyr vtlib 40 file * | grep -v 64-bit | grep -v ascii
> libvt_fmpi_la-vt_fmpiconst_1.o: ELF 32-bit MSB relocatable
> SPARC32PLUS Version 1, V8+ Required
> libvt_fmpi_la-vt_fmpiconst_2.o: ELF 32-bit MSB relocatable
> SPARC32PLUS Version 1, V8+ Required
> tyr vtlib 41
>
>
> Why are these two files 32-bit while all others are 64-bit as
> requested in "configure"? I would be grateful, if somebody
> can fix this problem. Thank you very much for your efforts
> in advance.
>
>
> Kind regards
>
> Siegmar
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users