Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] seg fault and undefined symbol in openmpi-1.9r28203
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-03-26 20:53:44


On Mar 22, 2013, at 8:34 AM, Siegmar Gross <Siegmar.Gross_at_[hidden]> wrote:

> openSuSE Linux 12.1, x86_64, SunC 5.12, 32-bit
> ----------------------------------------------
>
> linpc1 openmpi-1.9-Linux.x86_64.32_cc 113 tail log.make.Linux.x86_64.32_cc
> Making all in mpi/fortran/use-mpi-f08
> make[2]: Entering directory `.../ompi/mpi/fortran/use-mpi-f08'
> PPFC mpi-f08-sizeof.lo
> PPFC mpi-f08.lo
> "../../../../../openmpi-1.9r28203/ompi/mpi/fortran/use-mpi-f08/mpi-f08.F90",
> Line = 1, Column = 1: INTERNAL: Interrupt: Segmentation fault
> make[2]: *** [mpi-f08.lo] Error 1
> make[2]: Leaving directory `.../ompi/mpi/fortran/use-mpi-f08'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `.../ompi'
> make: *** [all-recursive] Error 1

Just to follow up on this thread for the web archives: I think we're talking about this error in a different thread (because we were too slow to answer this one -- sorry!). It looks to me like a compiler error.

> Solaris 10, x86_64 and sparc, SunC 5.12, 32-bit and 64-bit
> ----------------------------------------------------------
>
> sunpc1 openmpi-1.9-SunOS.x86_64.32_cc 16 tail -15 log.make.SunOS.x86_64.32_cc
> make[2]: Entering directory `.../opal/tools/wrappers'
> CC opal_wrapper.o
> "../../../../openmpi-1.9r28203/opal/include/opal/sys/ia32/atomic.h",
> line 173: warning: parameter in inline asm statement unused: %2
> "../../../../openmpi-1.9r28203/opal/include/opal/sys/ia32/atomic.h",
> line 193: warning: parameter in inline asm statement unused: %2
> CCLD opal_wrapper
> Undefined first referenced
> symbol in file
> opal_hwloc152_hwloc_solaris_get_chip_model ../../../opal/.libs/libopen-pal.so
> opal_hwloc152_hwloc_solaris_get_chip_type ../../../opal/.libs/libopen-pal.so
> ld: fatal: symbol referencing errors. No output written to .libs/opal_wrapper
> make[2]: *** [opal_wrapper] Error 2
> make[2]: Leaving directory `.../opal/tools/wrappers'

This one was fixed today on the OMPI trunk at SVN r28215.

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/