Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] mpirun trouble through ssh
From: Baptiste Robert (baptisterobert38_at_[hidden])
Date: 2013-03-24 16:50:49


Hi everybody !

Here's my problem. I've installed openmpi on my two machines running on
fedora 17. I've set the path and LD_LIBRARY_PATH correctly, mpirun and
mpicc work on the two machines without trouble.

My problem is when I try to run the helloWorld on all node through ssh
(already configure with certificate) nothing append, I've to kill mpi to
get the prompt back.

I launched this command : mpirun -d -host myRemoteNode -n 2 hello_c
And this give me :

[baptiste_at_baptiste RE51]$ mpirun -d -hostfile hosts hello_c
[baptiste.thinkFed:02666] procdir:
/tmp/openmpi-sessions-baptiste_at_baptiste.thinkFed_0/53471/0/0
[baptiste.thinkFed:02666] jobdir:
/tmp/openmpi-sessions-baptiste_at_baptiste.thinkFed_0/53471/0
[baptiste.thinkFed:02666] top: openmpi-sessions-baptiste_at_baptiste.thinkFed_0
[baptiste.thinkFed:02666] tmp: /tmp
[roommateServer:01102] procdir:
/tmp/openmpi-sessions-baptiste_at_roommateServer_0/53471/0/1
[roommateServer:01102] jobdir:
/tmp/openmpi-sessions-baptiste_at_roommateServer_0/53471/0
[roommateServer:01102] top: openmpi-sessions-baptiste_at_roommateServer_0
[roommateServer:01102] tmp: /tmp

And nothing else. But if I run the hello_c on a single machine,
separately, the job is done and work well.

If anyone have an idea it would be awesome.. I don't have a clue why
it isn't work.

Thank.