Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] modified hostfile does not work with openmpi1.7rc8
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-03-21 10:47:26


Hmmm...okay, let's try one more thing. Can you please add the following to your command line:

-mca ras_base_verbose 5 -mca rmaps_base_verbose 5

Appreciate your patience. For some reason, we are losing your head node from the allocation when we start trying to map processes. I'm trying to track down where this is happening so we can figure out why.

On Mar 20, 2013, at 10:32 PM, tmishima_at_[hidden] wrote:

>
>
> Hi Ralph,
>
> Here is the result on patched openmpi-1.7rc8.
>
> mpirun -v -np 8 -hostfile pbs_hosts -x OMP_NUM_THREADS
> --display-allocation /home/mishima/Ducom/testbed/mPre m02-ld
>
> ====================== ALLOCATED NODES ======================
>
> Data for node: node06 Num slots: 4 Max slots: 0
> Data for node: node05 Num slots: 4 Max slots: 0
>
> =================================================================
> [node06.cluster:21149] HOSTFILE: CHECKING FILE NODE node06 VS LIST NODE
> node05
> --------------------------------------------------------------------------
> A hostfile was provided that contains at least one node not
> present in the allocation:
>
> hostfile: pbs_hosts
> node: node06
>
> If you are operating in a resource-managed environment, then only
> nodes that are in the allocation can be used in the hostfile. You
> may find relative node syntax to be a useful alternative to
> specifying absolute node names see the orte_hosts man page for
> further information.
> --------------------------------------------------------------------------
>
> Regards,
> Tetsuya
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users