Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Possible bug in OpenMPI 1.6.3 in selecting v4 or v6 network addresses on the same adaptor
From: Iliev, Hristo (Iliev_at_[hidden])
Date: 2013-03-21 09:34:42


Hi,

You can use the btl_tcp_disable_family and oob_tcp_disable_family MCA
parameters to disable the use of a specific IP family addresses. Set both
parameters to 6 to disable IPv6 or set them both to 4 in order to disable
IPv4.

Kind regards,
Hristo

> -----Original Message-----
> From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]]
> On Behalf Of Antony Cleave
> Sent: Thursday, March 21, 2013 1:09 PM
> To: users_at_[hidden]
> Subject: [OMPI users] Possible bug in OpenMPI 1.6.3 in selecting v4 or v6
> network addresses on the same adaptor
>
> Hi
>
> I've been fighting trying to run comparitive test of IMB using OpenMPI
> 1.6.3 on the same node using an Intel Truescale card and the onboard
> Ethernet.
>
> Turns out that all of the problems were due to the IP v6 addresses being
> firewalled on the nodes but OpenMPI was trying to use the IPv6 addresses
> of the nodes in spite of me explicitly specifying the IP v4 address as in
the
> following example:
>
> mpirun --mca btl ^openib --mca mtl ^psm --mca btl_tcp_if_include eth0 --
> mca btl_tcp_if_include 10.141.0.0/16 --mca btl_base_verbose 30 -np 2 --
> hostfile ./hostfile ./IMB-MPI1 pingpong . . .
> [node041:16301] select: initializing btl component tcp [node041:16301]
btl:
> tcp: Searching for include address+prefix:
> 10.141.0.0 / 16
> [node041:16301] btl: tcp: Found match: 10.141.0.41 (eth0) [node041:16301]
> select: init of component tcp returned success [node041:16301] btl: tcp:
> attempting to connect() to address
> 2002:bccb:3a13:141:225:90ff:fe58:5986 on port 4
>
> When I tried to exclude the IP v6 addresses as well I'm told that --mca
> btl_tcp_if_include and --mca btl_tcp_if_exclude are mutually exclusive so
I
> assume that this is not the expected behaviour.
>
> I also cannot find a command line switch in the documentation to disable
> IPv6 or IPv4.
>
> To fix this I first manually deleted the ipv6 addresses on the two nodes
and it
> worked as expected. I then reenabled them unfirewalled the v6 addresses
> and it also worked correctly using those (in spite of specifying the IPv4
> address explicitly).
>
> This is all running on Scientific Linux release 6.3
>
> I haven't tried to reproduce this on a node without a TrueScale card in
but I
> do not seem why this would make any difference to the tcp component.
>
> Thanks
>
> Antony
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

--
Hristo Iliev, PhD - High Performance Computing Team
RWTH Aachen University, Center for Computing and Communication
Rechen- und Kommunikationszentrum der RWTH Aachen
Seffenter Weg 23, D 52074 Aachen (Germany)


  • application/pkcs7-signature attachment: smime.p7s