Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Minor bug: invalid values for opal_signal MCA parameter cause internal error
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-03-20 11:32:31


Simple to do - I added a clearer error message to the trunk and marked it for inclusion in the eventual v1.7.1 release. I'll have to let someone else do the docs as I don't fully grok the rationale behind it.

Thanks

On Mar 18, 2013, at 12:56 PM, Jeremiah Willcock <jewillco_at_[hidden]> wrote:

> If a user gives an invalid value for the opal_signal MCA parameter, such as in the command:
>
> mpirun -mca opal_signal x /bin/ls
>
> the error produced by Open MPI 1.6.3 is:
>
> --------------------------------------------------------------------------
> It looks like opal_init failed for some reason; your parallel process is
> likely to abort. There are many reasons that a parallel process can
> fail during opal_init; some of which are due to configuration or
> environment problems. This failure appears to be an internal failure;
> here's some additional information (which may only be relevant to an
> Open MPI developer):
>
> opal_util_register_stackhandlers failed
> --> Returned value -5 instead of OPAL_SUCCESS
> --------------------------------------------------------------------------
>
> which claims to be an internal error, not an invalid argument given by a user. That parameter also appears to be poorly documented in general (mentioned in ompi_info -a and on the mailing lists), and seems like it would be an incredibly useful debugging tool when running a crashing application under a debugger.
>
> -- Jeremiah Willcock
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users