Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] error when running mpirun
From: satya k (satya5509_at_[hidden])
Date: 2013-02-10 15:04:10


Hi everyone,

I m getting the below error when executing mpirun with hostfile option

$mpirun -np 4 -hostfile nodes ./hello

orted: error while loading shared libraries: libnuma.so.1: cannot open
shared object file: No such file or directory
--------------------------------------------------------------------------
A daemon (pid 11798) died unexpectedly with status 127 while attempting
to launch so we are aborting.

There may be more information reported by the environment (see above).

This may be because the daemon was unable to find all the needed shared
libraries on the remote node. You may set your LD_LIBRARY_PATH to have the
location of the shared libraries on the remote nodes and this will
automatically be forwarded to the remote nodes.
--------------------------------------------------------------------------
--------------------------------------------------------------------------
mpirun noticed that the job aborted, but has no info as to the process
that caused that situation.
--------------------------------------------------------------------------

Also checked with the echo $LD_LIBRARY_PATH command on the nodes, Its
giving output as /apps/mpi/lib where lib files exists.

Any suggestions... I could not find anything as I am a newbie..

---
Albatross