Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI 1.6 with Intel 11 Compiler
From: Matthias Jurenz (matthias.jurenz_at_[hidden])
Date: 2013-02-05 05:04:40


Did you verified that your icpc works properly? Can you compile other C++
applications with icpc?
It might be that your version of icpc isn't supported with that version of
gcc.

I've found a ticket where a similar problem was reported:
https://svn.open-mpi.org/trac/ompi/ticket/3077
The solution was installing a newer version of the Intel compiler.
You mentioned that you cannot do this... If that's so and you don't need
VampirTrace, then just re-configure Open MPI with the option '--disable-vt'.

Matthias

On Feb 4, 2013, at 7:11 AM, Clarinet <clarinet_at_[hidden]> wrote:
> Dear OpenMPI users,

> I am trying to compile OpenMPI 1.6 (1.6.3) with Intel 11.0.081 set of
compilers. The compilation fails with

> CXXLD otfprofile
otfprofile-create_latex.o: In function
`std::locale::_Impl::_M_remove_reference()':
./create_latex.cpp:
(.gnu.linkonce.t._ZNSt6locale5_Impl19_M_remove_referenceEv[.gnu.linkonce.t._ZNSt6locale5_Impl19_M_remove_referenceEv]+0x38):
undefined reference to `__sync_fetch_and_add_4'
make[10]: *** [otfprofile] Error 1
make[10]: Leaving directory
`/usr/local/programs/openmpi/openmpi-1.6.3/src/openmpi-1.6.3-amd64-
intel_11.0.081/ompi/contrib/vt/vt/extlib/otf/tools/otfprofile'

> Although I found some hints on the Internet I have not been able to
resolve the problem. The gcc version is 'gcc (Debian 4.3.2-1.1) 4.3.2'.
I cannot install newer Intel compiler version. Any ideas, please?

> My 'configure' is

> CC=icc CXX=icpc F77=ifort FC=ifort ./configure
--prefix=../../arch/${ARCH} --enable-shared --enable-static
--enable-mpirun-prefix-by-default --enable-mpi-threads --with-sge
--with-libnuma --with-hwloc

> Best regards,

> Jiri Polach