Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] libmpi_f90 shared lib version number change in 1.6.3
From: Jeff Squyres (jsquyres) (jsquyres_at_[hidden])
Date: 2013-01-16 12:12:09


On Jan 12, 2013, at 5:06 AM, Ake Sandgren <ake.sandgren_at_[hidden]> wrote:

> Was the change for libmpi_f90 in VERSION intentional or a typo?
> This is from openmpi 1.6.3
> libmpi_f90_so_version=4:0:1
> 1.6.1 had
> libmpi_f90_so_version=2:0:1

It was both intentional and a typo.

Specifically, it really should have bee 4:0:3. :-(

Meaning: we unintentionally broke the F90 ABI for 1.6.3 (specifically: OMPI applications compiled to utilize "use mpi"). :-( :-( :-(

This ABI compatibility will be restored in 1.6.4.

-----

See these commit messages for a fuller explanation:

    https://svn.open-mpi.org/trac/ompi/changeset/27471
    https://svn.open-mpi.org/trac/ompi/changeset/27558

The short explanation is that, in terms of the "use mpi" interface, all Open MPI 1.6.x versions are ABI compatible except 1.6.3.

These work:

- compile a "use mpi" OMPI application with 1.6.x (where x!=3), change your LD_LIBRARY_PATH to point to a different OMPI 1.6.x installation (where x!=3)

- compile a "use mpi" OMPI application with 1.6.3, use it with OMPI 1.6.3 installation

These do not:

- compile a "use mpi" OMPI application with 1.6.x (where x!=3), change your LD_LIBRARY_PATH to point an OMPI 1.6.3 installation

- compile a "use mpi" OMPI application with 1.6.3, use it with OMPI 1.6.x installation (where x!=3)

I will make an FAQ item about this so that the result is google-able.

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/