Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] Error running program : mca_oob_tcp_msg_send_handler: writev:failed: Bad file descriptor
From: borja mf (borjamunozfernandez_at_[hidden])
Date: 2013-01-16 07:46:09


Hello all.
I want to learn MPI and I've trying to setting up OMPI for first time on
three nodes. My config above:
Ubuntu server - master node: pruebaborja
2x Ubuntu Desktop - slaves node:
clienteprueba
clientepruebados 4 slots

Im running NFSv4 for sharing /home/mpiuser.
I want to test a plain "Hello world"but I can't make it working
successfully on node clienteprueba. This is the problem:

mpiuser_at_pruebaborja:~$ mpirun -np 6 --hostfile .mpi_hostfile ./holamundo
[clienteprueba:01993] [[64434,0], 2] -> [[64434,0],0]
mca_oob_tcp_msg_send_handler: writev:failed: Bad file descriptor (9) [sd =
9]
[clienteprueba:01993] [[64434,0], 2] routed:binomial: Connection to
lifeline [[64434,0],0] lost

However, with clientepruebados and pruebaborja only on my hostfile, it
works:

pruebaborja slots=1
clientepruebados slots=4
#clienteprueba slots=1

mpiuser_at_pruebaborja:~$ mpirun -np 6 --hostfile .mpi_hostfile ./holamundo
Hola, mundo, soy pruebaborja: 0 de 6
Hola, mundo, soy pruebaborja: 5 de 6
Hola, mundo, soy clientepruebados: 1 de 6
Hola, mundo, soy clientepruebados: 2 de 6
Hola, mundo, soy clientepruebados: 3 de 6
Hola, mundo, soy clientepruebados: 4 de 6

I've checked the OMPI versions on the machines and it's the same. I can't
understand why Im getting this error on clienteprueba; i've done the same
config on clientepruebados and clienteprueba. Anyone could help me to
solve this?

Sorry for my english.
Thanks in advance