Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Open MPI error in Windows
From: Kumar, Sudhir (kums_at_[hidden])
Date: 2013-01-09 16:47:18


Hi
I get the following error when trying to use OpenMPI on Windows. I was wondering if anyone has run into similar errors while using OpenMPI 1.6 on Windows.

C:\Test\pred2\tmp_pred2>"C:\\Program Files (x86)\\OpenMPI_v1.6-x64\\bin\\mpiexec" -x CXTC_LICENSE_FIL
E --bind-to-core --bysocket -np 3 "C:\\chap\\chears\\devel\\bin\\ParaMain.exe" -q "C:\\
Test\\pred2"\tmp_pred2\pred2.deck -w "C:\\Test\\pred2\\temp" -o "C:\\Test\\pred2"\tmp_pred2
   -f "C:\\Test\\pred2"\tmp_pred2\fort.21 -h "C:\\Test\\pred2"\tmp_pred2\fort.88 1>"C:\\Test\
\pred2"\tmp_pred2\pred2.stdo
[2ua73917cx:03812] opal_os_dirpath_create: Error: Unable to create the sub-directory ("C:) of ("C:\\Test
\\pred2\\temp"\openmpi-sessions-kums_at_2ua73917cx_0\14199\0\0), mkdir failed [1]
[2ua73917cx:03812] [[14199,0],0] ORTE_ERROR_LOG: Error in file ..\..\..\openmpi-1.6\orte\util\session_di
r.c at line 106
[2ua73917cx:03812] [[14199,0],0] ORTE_ERROR_LOG: Error in file ..\..\..\openmpi-1.6\orte\util\session_di
r.c at line 399
[2ua73917cx:03812] [[14199,0],0] ORTE_ERROR_LOG: Error in file ..\..\..\openmpi-1.6\orte\mca\ess\hnp\ess
_hnp_module.c at line 337
--------------------------------------------------------------------------
It looks like orte_init failed for some reason; your parallel process is
likely to abort. There are many reasons that a parallel process can
fail during orte_init; some of which are due to configuration or
environment problems. This failure appears to be an internal failure;
here's some additional information (which may only be relevant to an
Open MPI developer):

  orte_session_dir failed
  --> Returned value Error (-1) instead of ORTE_SUCCESS
--------------------------------------------------------------------------
[2ua73917cx:03812] [[14199,0],0] ORTE_ERROR_LOG: Error in file ..\..\..\openmpi-1.6\orte\runtime\orte_in
it.c at line 128
--------------------------------------------------------------------------
It looks like orte_init failed for some reason; your parallel process is
likely to abort. There are many reasons that a parallel process can
fail during orte_init; some of which are due to configuration or
environment problems. This failure appears to be an internal failure;
here's some additional information (which may only be relevant to an
Open MPI developer):

  orte_ess_set_name failed
  --> Returned value Error (-1) instead of ORTE_SUCCESS
--------------------------------------------------------------------------
[2ua73917cx:03812] [[14199,0],0] ORTE_ERROR_LOG: Error in file ..\..\..\..\..\openmpi-1.6\orte\tools\ort
erun\orterun.c at line 697