Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] grpcomm component hier gone...
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-01-03 10:14:16


On Jan 3, 2013, at 7:07 AM, Ake Sandgren <ake.sandgren_at_[hidden]> wrote:

> On Thu, 2013-01-03 at 07:00 -0800, Ralph Castain wrote:
>> On Jan 3, 2013, at 6:52 AM, Ake Sandgren <ake.sandgren_at_[hidden]> wrote:
>>
>>> On Thu, 2013-01-03 at 06:18 -0800, Ralph Castain wrote:
>>>> On Jan 3, 2013, at 3:01 AM, Ake Sandgren <ake.sandgren_at_[hidden]> wrote:
>>>>
>>>>> On Thu, 2013-01-03 at 11:54 +0100, Ake Sandgren wrote:
>>>>>> On Thu, 2013-01-03 at 11:15 +0100, Ake Sandgren wrote:
>>>>>>> Hi!
>>>>>>>
>>>>>>> The grpcomm component hier seems to have vanished between 1.6.1 and
>>>>>>> 1.6.3.
>>>>>>> Why?
>>>>>>> It seems that the version of slurm we are using (not the latest at the
>>>>>>> moment) is using it for startup.
>>>>
>>>> It should be using PMI if you are directly launching processes via srun, and should not be using hier any more.
>>>
>>> Shouldn't the grpcomm pmi component be turned on by default then, if it
>>> is needed?
>>
>> It should be
>
> Well, it isn't :-)
> configure says:
> --- MCA component grpcomm:pmi (m4 configuration macro)
> checking for MCA component grpcomm:pmi compile mode... dso
> checking if user requested PMI support... no
> checking if MCA component grpcomm:pmi can compile... no

Ah - that is the problem. You need to configure --with-pmi=<wherever-slurms-pmi.h-is-located>

>
>>> So what is the real problem here?
>>
>> Do you have PMI installed and running on your system? I think that is the source of the trouble - if PMI isn't running, then this will fail.
>
> Not sure what you mean here. slurm's pmi module is available (and Intel
> MPI can use it if i point it to it).

Yeah, we need to be pointed to it just like Intel.

>
> Anyway, I think that if there is code that tries to use the hier
> component it shouldn't have been removed.

Agreed - it looks like something picked up an unintended change. Just trying to help you work with it as I don't know when a 1.6.4 will occur.

>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users