Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpirun - All Nodes Filled
From: Ralph Castain (rhc_at_[hidden])
Date: 2013-01-03 10:02:24


Hmmm...I would say there is a bug in 1.7 then! It isn't recognizing the word "localhost" as being your local host. I'll take a look at it.

Thanks!

On Jan 3, 2013, at 6:53 AM, Chuck Mosher <chuckmosher_at_[hidden]> wrote:

> Simple question for today !
>
> I am working on converting a public domain code suite (http://www.JavaSeis.org) to use openmpi rather than mpiJava.
> So far, all has gone well, other than the usual issues with getting all the paths and variables straightened out.
> For automation purposes, I would like to be able to specify everything from the command line, rather than using files.
>
> Why does this command work:
>
> chuck-> /usr/local/bin/mpirun -np 1 /usr/bin/java -version
> java version "1.6.0_37"
> Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-10M3909)
> Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)
>
> But this one does not:
>
> chuck-> /usr/local/bin/mpirun -np 1 -host localhost /usr/bin/java -version
> --------------------------------------------------------------------------
> All nodes which are allocated for this job are already filled.
> --------------------------------------------------------------------------
>
> Nor does this one:
>
> chuck-> cat hostfile
> localhost slots=2
>
> chuck->/usr/local/bin/mpirun -np 1 -hostfile hostfile /usr/bin/java -cp . -version
> --------------------------------------------------------------------------
> All nodes which are allocated for this job are already filled.
> --------------------------------------------------------------------------
>
>
> For reference:
>
> chuck-> /usr/local/bin/mpirun -version
> mpirun (Open MPI) 1.7rc5
>
> Report bugs to http://www.open-mpi.org/community/help/
>
> chuck-> uname -a
> Darwin iMac.local 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun 7 16:32:41 PDT 2011; root:xnu-1504.15.3~1/RELEASE_X86_64 x86_64
>
> My build was done with "configure --enable-mpi-java --prefix=/usr/local".
>
> Thanks for any insight !
>
> Chuck Mosher
> chuckmosher_at_[hidden]
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users