Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI with cMake on Windows
From: MM (finjulhich_at_[hidden])
Date: 2012-12-21 06:14:12


On 18 December 2012 22:04, Stephen Conley <conleysa_at_[hidden]> wrote:

> Hello,****
>
> ** **
>
> I have installed CMake version 2.8.10.2 and OpenMPI version 1.6.2 on a 64
> bit Windows 7 computer. ****
>
> ** **
>
> OpenMPI is installed in “C:\program files\OpenMPI” and the path has been
> updated to include the bin subdirectory.****
>
> ** **
>
> In the cmakelists.txt file, I have: find_package(MPI REQUIRED)****
>
> ** **
>
> When I run cmake, I receive the following error:****
>
> ** **
>
> *C:\Users\steve\workspace\Dales\build>cmake ..\src -G "MinGW Makefiles"*
>
> *CMake Error at C:/Program Files (x86)/CMake
> 2.8/share/cmake-2.8/Modules/FindPack*
>
> *ageHandleStandardArgs.cmake:97 (message):*
>
> * Could NOT find MPI_C (missing: MPI_C_LIBRARIES)*
>
> *Call Stack (most recent call first):*
>
> * C:/Program Files (x86)/CMake
> 2.8/share/cmake-2.8/Modules/FindPackageHandleStan*
>
> *dardArgs.cmake:291 (_FPHSA_FAILURE_MESSAGE)*
>
> * C:/Program Files (x86)/CMake
> 2.8/share/cmake-2.8/Modules/FindMPI.cmake:587 (fi*
>
> *nd_package_handle_standard_args)*
>
> * CMakeLists.txt:9 (find_package)*
>
> * *
>
> * *
>
> *-- Configuring incomplete, errors occurred!*
>
> * *
>
> Any ideas as to what I am missing?****
>
> ** **
>
Try to google for some changes I've made to findmpi.cmake that worked for
windows a few years ago.
They have to do with an if test syntax in that file that the cmd.exe
doesn't accept
This was 2.8.4 i believe but probably still true now.
I'll answer with more details in a month time.

Regards,