Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi-1.9a1r27674 on Cygwin-1.7.17
From: marco atzeri (marco.atzeri_at_[hidden])
Date: 2012-12-19 06:28:23


On 12/19/2012 11:04 AM, Siegmar Gross wrote:
> Hi
>
>> On 12/18/2012 6:55 PM, Jeff Squyres wrote:
>>> ...but only of v1.6.x.
>>
>> okay, adding development version on Christmas wishlist
>> ;-)
>
> Can you build the package with thread and Java support?
>
> --enable-mpi-java \
> --enable-opal-multi-threads \
> --enable-mpi-thread-multiple \
> --with-threads=posix \
>
> I could build openmpi-1.6.4 with thread support without a problem
> for Cygwin 1.7.17 but I failed to build openmpi-1.9 until now.
>

working on openmpi-1.7rc5.
It needs some cleaning and after I need to test.

java surely no as there is no cygwin Java.

--with-threads=posix yes

not tested yet
     --enable-opal-multi-threads \
     --enable-mpi-thread-multiple \

>
> Kind regards
>
> Siegmar
>

Regards
Marco