Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] openmpi-1.9a1r27674 on Cygwin-1.7.17
From: Siegmar Gross (Siegmar.Gross_at_[hidden])
Date: 2012-12-19 05:04:37


Hi

> On 12/18/2012 6:55 PM, Jeff Squyres wrote:
> > ...but only of v1.6.x.
>
> okay, adding development version on Christmas wishlist
> ;-)

Can you build the package with thread and Java support?

  --enable-mpi-java \
  --enable-opal-multi-threads \
  --enable-mpi-thread-multiple \
  --with-threads=posix \

I could build openmpi-1.6.4 with thread support without a problem
for Cygwin 1.7.17 but I failed to build openmpi-1.9 until now.

> > On Dec 18, 2012, at 10:32 AM, Ralph Castain wrote:
> >
> >> Also, be aware that the Cygwin folks have already released a
> >> fully functional port of OMPI to that environment as a package.
> >> So if you want OMPI on Cygwin, you can just download and
> >> install the Cygwin package - no need to build it yourself.

Kind regards

Siegmar