Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] problem configuring openmpi-1.6.4a1r27643 on Linux
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-12-18 08:40:01


On Dec 13, 2012, at 2:39 AM, Siegmar Gross wrote:

> I found the error with your hint. For Open MPI 1.6.x I must also
> specify "F77" and "FFLAGS" for the Fortran 77 compiler. Otherwise
> it uses "gfortran" from the GNU package. "gfortran" worked for the
> 64 bit version and didn't work for the 32 bit version. (that's the
> reason why I got only an error for the 32 bit version).

Yep, sorry about that -- we revamped the Fortran support in v1.7 and beyond such that the following are used with configure:

v1.6.x and earlier: F77, FFLAGS, FC, FCFLAGS
v1.7.0 and later: FC, FCFLAGS

I.e., we consolidated down to one Fortran compiler for v1.7.0 and later (and similarly deprecated mpif77 and mpif90 -- mpifort is now preferred in v1.7.0 and layer).

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/