Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] problem configuring openmpi-1.6.4a1r27643 on Linux
From: Siegmar Gross (Siegmar.Gross_at_[hidden])
Date: 2012-12-12 10:33:11


Hi,

I tried to build openmpi-1.6.4a1r27643 on several platforms
(Solaris Sparc, Solaris x86_64, and Linux x86_64) with Solaris
Studio C (Sun C 5.12) in 32 and 64 bit mode. "configure" broke
on Linux (openSuSE Linux 12.1) for the 32 bit version with the
following error:

...
checking if Fortran 77 compiler supports INTEGER*16... yes
checking size of Fortran 77 INTEGER*16... configure: error:
  Could not determine size of INTEGER*16
linpc1 openmpi-1.6.4-Linux.x86_64.32_cc 144

I could compile a 32 bit version of openmpi-1.9a1r27668 on the
machine without problems.

linpc1 openmpi-1.9-Linux.x86_64.32_cc 148 grep "INTEGER\*16"
log.configure.Linux.x86_64.32_cc
checking if Fortran compiler supports INTEGER*16... no
linpc1 openmpi-1.9-Linux.x86_64.32_cc 149

Does anybody have an idea why "configure" broke for
openmpi-1.6.4a1r27643 and how I can fix the problem? Thank you
very much for any help in advance.

Kind regards

Siegmar