Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Serveral issue in mpirun on macosx 10.8.2
From: Extreme Programming (dmasondev_at_[hidden])
Date: 2012-12-12 07:11:30


Hi, I have just installed openmpi 1.7 on my macosx 10.8.2 because i need
java bining.
Installation works fine, compilation too but when i executed the "mpirun -n
4 myfile" i get this error:

MacBook-Pro:Desktop rainmaker$ mpirun -n 4 a.out
[MacBook-Pro.local:18481] mca: base: component_find: unable to open
/usr/local/lib/openmpi/mca_ess_slurmd:
dlopen(/usr/local/lib/openmpi/mca_ess_slurmd.so, 9): Symbol not found:
_orte_jmap_t_class
  Referenced from: /usr/local/lib/openmpi/mca_ess_slurmd.so
  Expected in: flat namespace
 in /usr/local/lib/openmpi/mca_ess_slurmd.so (ignored)
[MacBook-Pro.local:18481] mca: base: component_find: unable to open
/usr/local/lib/openmpi/mca_errmgr_default:
dlopen(/usr/local/lib/openmpi/mca_errmgr_default.so, 9): Symbol not found:
_orte_errmgr_base_error_abort
  Referenced from: /usr/local/lib/openmpi/mca_errmgr_default.so
  Expected in: flat namespace
 in /usr/local/lib/openmpi/mca_errmgr_default.so (ignored)
[MacBook-Pro.local:18481] mca: base: component_find: unable to open
/usr/local/lib/openmpi/mca_routed_cm:
dlopen(/usr/local/lib/openmpi/mca_routed_cm.so, 9): Symbol not found:
_orte_message_event_t_class
  Referenced from: /usr/local/lib/openmpi/mca_routed_cm.so
  Expected in: flat namespace
 in /usr/local/lib/openmpi/mca_routed_cm.so (ignored)
[MacBook-Pro.local:18481] mca: base: component_find: unable to open
/usr/local/lib/openmpi/mca_routed_linear:
dlopen(/usr/local/lib/openmpi/mca_routed_linear.so, 9): Symbol not found:
_orte_message_event_t_class
  Referenced from: /usr/local/lib/openmpi/mca_routed_linear.so
  Expected in: flat namespace
 in /usr/local/lib/openmpi/mca_routed_linear.so (ignored)
[MacBook-Pro.local:18481] mca: base: component_find: unable to open
/usr/local/lib/openmpi/mca_grpcomm_basic:
dlopen(/usr/local/lib/openmpi/mca_grpcomm_basic.so, 9): Symbol not found:
_opal_profile
  Referenced from: /usr/local/lib/openmpi/mca_grpcomm_basic.so
  Expected in: flat namespace
 in /usr/local/lib/openmpi/mca_grpcomm_basic.so (ignored)
[MacBook-Pro.local:18481] mca: base: component_find: unable to open
/usr/local/lib/openmpi/mca_grpcomm_hier:
dlopen(/usr/local/lib/openmpi/mca_grpcomm_hier.so, 9): Symbol not found:
_orte_daemon_cmd_processor
  Referenced from: /usr/local/lib/openmpi/mca_grpcomm_hier.so
  Expected in: flat namespace
 in /usr/local/lib/openmpi/mca_grpcomm_hier.so (ignored)
[MacBook-Pro:18481] *** Process received signal ***
[MacBook-Pro:18481] Signal: Segmentation fault: 11 (11)
[MacBook-Pro:18481] Signal code: Address not mapped (1)
[MacBook-Pro:18481] Failing at address: 0x14
[MacBook-Pro:18481] [ 0] 2 libsystem_c.dylib
0x00007fff820308ea _sigtramp + 26
[MacBook-Pro:18481] [ 1] 3 ???
0x00007fff59070458 0x0 + 140734687020120
[MacBook-Pro:18481] [ 2] 4 libopen-rte.5.dylib
0x0000000106bd7658 orte_rmaps_base_map_job + 984
[MacBook-Pro:18481] [ 3] 5 libopen-rte.5.dylib
0x0000000106c1a0a0 opal_libevent2019_event_base_loop + 1888
[MacBook-Pro:18481] [ 4] 6 mpirun
 0x0000000106b916e1 orterun + 5137
[MacBook-Pro:18481] [ 5] 7 mpirun
 0x0000000106b90290 main + 32
[MacBook-Pro:18481] [ 6] 8 libdyld.dylib
0x00007fff8ac597e1 start + 0
[MacBook-Pro:18481] [ 7] 9 ???
0x0000000000000004 0x0 + 4
[MacBook-Pro:18481] *** End of error message ***
Segmentation fault: 11

for resolving it, i have exported the LD_LIBRARY_PATH = /usr/local/bin and
I used the same configuration of my last openmpi's installation.
Please help me to solve this issue.

Thank you very much.