Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] error configuring OpenMPI 1.6.3 with gcc 4.7.2
From: Paul Hatton (p.s.hatton_at_[hidden])
Date: 2012-12-06 16:18:28


Thanks. Is this with gcc in the default location (/usr/bin/gcc) or elsewhere? It may not be relevant, but I built v4.7.2 and installed it outside of the system area:

[appmaint_at_bb2login04 openmpi-1.6.3]$ which gcc
/gpfs/apps/gcc/v4.7.2/bin/gcc
[appmaint_at_bb2login04 openmpi-1.6.3]$ gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/gpfs/apps/gcc/v4.7.2/libexec/gcc/x86_64-unknown-linux-gnu/4.7.2/lto-wrapper
Target: x86_64-unknown-linux-gnu
Configured with: ./configure --prefix=/gpfs/apps/gcc/v4.7.2 --disable-multilib
Thread model: posix
gcc version 4.7.2 (GCC)
[appmaint_at_bb2login04 openmpi-1.6.3]$ module unload apps/gcc
[appmaint_at_bb2login04 openmpi-1.6.3]$ which gcc
/usr/bin/gcc

clutching at straws a bit here ... but I have built it with Intel 2013.0.079 which is also installed in the applications area and loaded with a module.

-- 
Paul Hatton
High Performance Computing and Visualisation Specialist
IT Services, The University of Birmingham
Ph: 0121-414-3994  Mob: 07785-977340  Skype: P.S.Hatton
[Service Manager, Birmingham Environment for Academic Research]
[Also Technical Director, IBM Visual and Spatial Technology Centre]
> -----Original Message-----
> From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]] On
> Behalf Of Gunter, David O
> Sent: 06 December 2012 21:06
> To: Open MPI Users
> Subject: Re: [OMPI users] error configuring OpenMPI 1.6.3 with gcc
> 4.7.2
> 
> I just tried with the following:
> 
> $ gcc --version
> gcc (GCC) 4.7.2
> Copyright (C) 2012 Free Software Foundation, Inc.
> This is free software; see the source for copying conditions.  There is
> NO
> warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
> PURPOSE.
> 
> $ ./configure  --prefix=/tmp/dog/openmpi/1.6.3-gcc-4.7.2 F77=gfortran
> FC=gfortran CC=gcc CXX=c++ --with-
> platform=contrib/platform/lanl/tlcc2/optimized-panasas 2>&1 | tee
> test.log
> 
> configure completed without error as did the subsequent make.
> 
> Here's the relevant part of the configure output:
> 
> ...
> checking Fortran 90 kind of MPI_INTEGER_KIND (selected_int_kind(9))...
> 4
> checking Fortran 90 kind of MPI_ADDRESS_KIND (selected_int_kind(18))...
> 8
> checking Fortran 90 kind of MPI_OFFSET_KIND (selected_int_kind(18))...
> (cached) 8
> ...
> 
> --
> David Gunter
> HPC-3: Infrastructure Team
> Los Alamos National Laboratory
> 
> 
> 
> 
> On Dec 6, 2012, at 1:42 PM, Paul Hatton wrote:
> 
> > I've searched the FAQ but not come up with anything about this ...
> with OpenMPI 1.6.3 and gcc 4.7.2, when I
> >
> > ./configure  --prefix=/gpfs/apps/openmpi/1.6.3/gcc_4.7.2-tm-ib \
> >  F77=gfortran FC=gfortran CC=gcc CXX=c++ \
> >  --with-tm=/gpfs/sysapps/torque/4.1.2 \
> >  --with-openib \
> >  2>&1|tee ../logs/configure-`date +%y_%m_%d_%Hh%Mm`.log
> >
> > configure fails with
> >
> > checking Fortran 90 kind of MPI_INTEGER_KIND
> (selected_int_kind(9))...
> >    configure: error: Could not determine kind of
> selected_int_kind(MPI_INTEGER_KIND)
> >
> > Has anyone built 1.6.3 with gcc 4.7.2? It build fine with Intel
> 2013.0.079 and also the system (Scientific Linux 6.3) gcc which is
> 4.4.6
> >
> > I've attached the output from the configure command.
> >
> > Thanks
> >
> > --
> > Paul Hatton
> > High Performance Computing and Visualisation Specialist
> > IT Services, The University of Birmingham
> > Ph: 0121-414-3994  Mob: 07785-977340  Skype: P.S.Hatton
> > [Service Manager, Birmingham Environment for Academic Research]
> > [Also Technical Director, IBM Visual and Spatial Technology Centre]
> >
> > <configure-
> 12_12_06_19h48m.log>_______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
> 
> 
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users