Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Romio and OpenMPI builds
From: Eric Chamberland (Eric.Chamberland_at_[hidden])
Date: 2012-12-03 19:12:27


Le 12/03/2012 05:37 PM, Brock Palen a écrit :
> I was trying to use hints with ROMIO and lustre prompted by another post on this list.
>
> I have a simple MPI-IO code and I cannot using the notes I find set the lustre striping using the config file and setting ROMIO_HINTS.
>
> Question:
>
> How can I check which ADIO drivers ROMIO in OPenMPI was built with when I built it?
> Can I make ROMIO go into 'verbose' mode and have it print what it is setting all its values to?
Try "ompi_info -a" and check for lustre in the output:

ompi_info -a | grep -i romio
...
                   MCA io: information "io_romio_user_configure_params"
(value: <--with-file-system=testfs+ufs+nfs+lustre>, data source: default
value)
                           User-specified command line parameters passed
to ROMIO's configure script
                   MCA io: information
"io_romio_complete_configure_params" (value:
<--with-file-system=testfs+ufs+nfs+lustre CFLAGS='-DNDEBUG -O3 -xHOST
-Wall -finline-functions -fno-strict-aliasing -restrict -pthread'
CPPFLAGS='
-I/clumeq/src/Open-MPI/1.6.3/intel/openmpi-1.6.3/opal/mca/hwloc/hwloc132/hwloc/include
-I/clumeq/src/Open-MPI/1.6.3/intel/Build/opal/mca/hwloc/hwloc132/hwloc/include
-I/usr/include/infiniband -I/usr/include/infiniband' FFLAGS='' LDFLAGS='
' --enable-shared --enable-static
--with-file-system=testfs+ufs+nfs+lustre
--prefix=/software/MPI/openmpi/1.6.3_intel --with-mpi=open_mpi
--disable-aio>, data source: default value)
                           Complete set of command line parameters
passed to ROMIO's configure script

Eric