Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] 0xc000007b error exit on 64-bit Windows 7
From: Damien (damien_at_[hidden])
Date: 2012-12-03 12:19:39


I just tried it on a clean VM, the 64-bit OpenMPI installer does install
to Program Files (x86). That's not the end of the world, but you have
to watch your paths.

Miroslav, when you ran the installer did you say yes to adding OpenMPI
to the system path? If you installed both 32 and 64-bit binaries, and
added both to the system path, it will typically just append the paths.
So if you installed 32-bit first, then 64-bit, whenever you run
something it will load the 32-bit OpenMPI runtime first, even running
64-bit, which will cause that bad image error. I think that's why your
32-bit run works and 64-bit doesn't.

I suggest uninstalling both 32 and 64-bit OpenMPIs, make sure they're
removed from the path, then reinstall them *without* putting them into
the system path, and try again from there. You'll have to set your
paths manually, but you'll be running with the right binaries each time.

Damien

On 03/12/2012 9:55 AM, Iliev, Hristo wrote:
> Hi,
>
> 0xC000007B is STATUS_INVALID_IMAGE_FORMAT. It mostly means that some of the
> dynamic link libraries (DLLs) that the executable is linked against are of
> different "bitness", e.g. 32-bit. It could be a packaging error in Open MPI,
> or it could be messed up installation. You could use the Dependency Walker
> tool to examine the list of DLLs that the executable depends upon and see
> which one is the culprit. Dependency Walker is available here:
>
> http://www.dependencywalker.com/
>
> Which brings me to the question: why the win64 version of Open MPI is
> installed in "Program Files (x86)", where 32-bit things go?!
>
> Hope that helps.
>
> Kind regards,
> Hristo
>
> --
> Hristo Iliev, Ph.D. -- High Performance Computing
> RWTH Aachen University, Center for Computing and Communication
> Rechen- und Kommunikationszentrum der RWTH Aachen
> Seffenter Weg 23, D 52074 Aachen (Germany)
>
>
>> -----Original Message-----
>> From: users-bounces_at_[hidden] [mailto:users-bounces_at_[hidden]]
>> On Behalf Of Ilias Miroslav
>> Sent: Monday, December 03, 2012 3:40 PM
>> To: users_at_[hidden]
>> Subject: [OMPI users] 0xc000007b error exit on 64-bit Windows 7
>>
>> Dear experts,
>>
>> I just installed http://www.open-
>> mpi.org/software/ompi/v1.6/downloads/OpenMPI_v1.6.1-1_win64.exe on
>> our Intel i7 64-bit Windows 7 system.
>>
>>
>> When I try to run some executable, I am getting error "Application Error
> The
>> application was unable to start correctly (0xc000007b)..."
>>
>> Any help please ? The "C:\Program Files (x86)\OpenMPI_v1.6.1-x64\bin"
>> string is in my %Path% variable.
>>
>> Yours, Miro
>>
>> PS: On 32-bit Windows 7 the 32-bit OpenMPI application works fine.
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users