Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] Can not turn off C++ build.
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-11-28 16:17:35


I'll bet we're not disabling the C++ test properly when you disable the C++ bindings. Bummer. I'll file a bug, but I don't know when that will be fixed.

However, this kind of error typically only occurs when your C++ compiler fails altogether (e.g., it's broken). Check the config.log file and see what it says happened for this specific test -- it may well be that your C++ compiler is faulty and needs to be fixed anyway.

On Nov 28, 2012, at 2:19 PM, Ray Sheppard wrote:

>
>
> Hello,
> I am trying to build OpenMPI 1.6.3 on an IBM/Intel RHEL-6 cluster.
> I tried building with variations (meaning enable-...=no, disable-,
> changing switch order, etc.) of this:
>
> ./configure CC=icc CFLAGS="-xT -O2" F77=ifort FFLAGS="-xT -O2"
> FC=ifort FCFLAGS="-xT -O2" --enable-mpi-cxx=no --disable-mpi-cxx-seek
> --enable-static --disable-shared --with-threads=posix
> --prefix=/N/soft/rhel6/openmpi/intel/openmpi-1.6.3
>
> I first tried using icpc as a CXX compiler but it dies shortly after
> checking the alignment of bool. C++ bindings are not that popular so I
> decided to just turn them off. Now, it just picks up g++ and tries
> building the C++ bindings anyway:
>
> ** C++ compiler and preprocessor
> checking for g++... g++
> checking whether we are using the GNU C++ compiler... yes
> checking whether g++ accepts -g... yes
> checking dependency style of g++... gcc3
> checking how to run the C++ preprocessor... g++ -E
> checking for the C++ compiler vendor... gnu
> checking if g++ supports -finline-functions... yes
> configure: WARNING: -finline-functions has been added to CXXFLAGS
> checking if C and C++ are link compatible... yes
> checking for C++ optimization flags... -O3 -DNDEBUG -finline-functions
> checking size of bool... 0
> checking alignment of bool... configure: WARNING: *** Problem running
> configure test!
> configure: WARNING: *** See config.log for details.
> configure: error: *** Cannot continue.
>
>
> It still errors. I am happy to just kill C++ but it won't. What is
> wrong? Thanks.
> Ray
>
> --
> Respectfully,
> Ray Sheppard
> RSheppar_at_[hidden]
> http://pti.iu.edu/sciapt
> 317-274-0016
>
> Principal Analyst
> Scientific Applications and Performance Tuning
> Research Technologies
> University Information Technological Services
> IUPUI campus
> Indiana University
>
> My "pithy" saying: Science is the art of translating the world
> into language. Unfortunately, that language is mathematics.
> Bumper sticker wisdom: Make it idiot-proof and they will make a
> better idiot.
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/