Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] CentOS 6.3 & OpenMPI 1.6.3
From: Pavel Mezentsev (pavel.mezentsev_at_[hidden])
Date: 2012-11-28 03:52:39


You can try downloading and installing a fresher version of MXM from
mellanox web site. There was a thread on the list with the same problem,
you can search for it.

2012/11/28 Joseph Farran <jfarran_at_[hidden]>

> Howdy.
>
> I a have a stock CentOS 6.3 OS and a Mellanox MT26428 card.
>
> I installed the Mellanox OFED MLNX_OFED_LINUX-1.5.3-3.1.0-**rhel6.3-x86_64
> which installed just fine. Rebooted the system and when I try building
> OpenMPI 1.6.3, it aborts with:
>
> mtl_mxm_send.c: In function 'ompi_mtl_mxm_isend':
> mtl_mxm_send.c:183: error: 'MXM_REQ_FLAG_SEND_SYNC' undeclared (first use
> in this function)
> make[2]: *** [mtl_mxm_send.lo] Error 1
> make[2]: *** Waiting for unfinished jobs....
> make[2]: Leaving directory `/data/apps/sources/openmpi-1.**
> 6.3/ompi/mca/mtl/mxm'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/data/apps/sources/openmpi-1.**6.3/ompi'
> make: *** [all-recursive] Error 1
>
>
> My configure options are:
>
> --with-sge \
> --with-threads \
> --with-hwloc \
> --with-openib \
> --enable-mpi-thread-multiple \
> --with-mxm=/opt/mellanox/mxm \
> --with-mxm-libdir=/opt/**mellanox/mxm/lib \
> --with-fca=/opt/mellanox/fca \
> --enable-heterogeneous \
> --enable-openib-connectx-xrc \
>
>
> Has anyone been able to compile OpenMPI 1.6.3 with the Mellanox OFED on
> CentOS 6.3?
>
> Joseph
> ______________________________**_________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/**mailman/listinfo.cgi/users>
>