Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Multiple RPM build fails
From: Jakub Nowacki (jakub.nowacki_at_[hidden])
Date: 2012-11-26 07:41:58


Hi Jeff,

Thanks for the information. Sorry that I'm posting it here but bugs mailing
list/Trac rejected my e-mail.

 I've tested the SRPM and I was able to compile it correctly on both RHEL 5
and CentOS 6 with multiple packages on, i.e:

rpmbuild -bb --define 'build_all_in_one_rpm 0' --define 'configure_options
--with-sge' /usr/src/redhat/SPECS/openmpi-
1.6.3.spec

Hence, the modified spec-file seems to fix the issue.

Cheers,

Jakub

On 21 November 2012 12:47, Jeff Squyres <jsquyres_at_[hidden]> wrote:

> Greetings Jakub; thanks for the bug report.
>
> I've replicated your error. Off the top of my head, I don't see why this
> is happening. I see that rpmbuild has compressed the man pages in the
> multi-build scenario (e.g., BUILDROOT contains
> /usr/share/man/man3/MPI_<foo>.3.gz -- NOT .../man3/MPI_<foo>.3). So I see
> that the error is *correct*, but I'm not sure offhand why it's not picking
> up the .3.gz files instead of the .3 files.
>
> I've opened https://svn.open-mpi.org/trac/ompi/ticket/3410 to track this
> issue.
>
>
> On Nov 21, 2012, at 4:06 AM, Jakub Nowacki wrote:
>
> > Hi,
> >
> > I tried to build OpenMPI 1.6.3 RPM on RHEL 5.5 and CentOS 6.3 for usage
> with SGE (--with-sge) but the build of multiple RPMs fail with the error:
> >
> > Processing files: openmpi-runtime-1.6.3-1.x86_64
> > error: File not found: /root/rpmbuild/BUILDROOT/
> > openmpi-1.6.3-1.x86_64/usr/share/man/man3/MPI_Comm_remote_size.3
> > error: File not found:
> /root/rpmbuild/BUILDROOT/openmpi-1.6.3-1.x86_64/usr/share/man/man3/MPI_Comm_remote_group.3
> > Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.0HfCky
> >
> > [...]
> >
> > RPM build errors:
> > File not found:
> /root/rpmbuild/BUILDROOT/openmpi-1.6.3-1.x86_64/usr/share/man/man3/MPI_Comm_remote_size.3
> > File not found:
> /root/rpmbuild/BUILDROOT/openmpi-1.6.3-1.x86_64/usr/share/man/man3/MPI_Comm_remote_group.3
> > *** FAILURE BUILDING MULTIPLE RPM!
> >
> > Indeed, these man pages does not seem to be there but there are gzipped
> files there:
> >
> > -rw-r--r-- 1 root root 884 Nov 20 15:29
> /root/rpmbuild/BUILDROOT/openmpi-1.6.3-1.x86_64/usr/share/man/man3/MPI_Comm_remote_group.3.gz
> > -rw-r--r-- 1 root root 904 Nov 20 15:29
> /root/rpmbuild/BUILDROOT/openmpi-1.6.3-1.x86_64/usr/share/man/man3/MPI_Comm_remote_size.3.gz
> >
> > Interestingly, single RPM build is successful. I get the same error on
> both RHEL 5.5 and CentOS 6.3 using SRPM and tar package along with
> buildrpm.sh script. I have tried to find a solution but most of the sources
> I have found use single RPM build.
> >
> > Thank you very much for the help.
> >
> > Regards,
> >
> > Jakub Nowacki
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>