Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] configuration openMPI problem
From: Rayson Ho (raysonlogin_at_[hidden])
Date: 2012-11-24 01:32:56


In your shell, run:

export PATH=$PATH

And then rerun configure again with the original parameters again - it
should find icc & ifort this time.

Rayson

==================================================
Open Grid Scheduler - The Official Open Source Grid Engine
http://gridscheduler.sourceforge.net/

On Fri, Nov 23, 2012 at 9:22 PM, Diego Avesani <diego.avesani_at_[hidden]> wrote:
> hi,
> thank for your replay.
>
> I currently use ifort to compile my program. I write also a hello program
> for icc and it works.
> After that I have run
>
> ./configure --prefix=/usr/local
>
> without specified any compiler and it seem to work. Now I have a ompi-1.6
> folder in my opt folder. A question: Can I now compile a program with
> openmpi and intel fortran compiler?
> if yes do you know some good tutorial
>
> again thank for you time
>
>
> Diego
>
>
>
>
>
> On 23 November 2012 20:45, Ralph Castain <rhc_at_[hidden]> wrote:
>>
>> I believe what it is telling you is that icc is not in your PATH. Please
>> check that icc, icpc, and ifort are all in your PATH.
>>
>>
>> On Nov 23, 2012, at 11:35 AM, Diego Avesani <diego.avesani_at_[hidden]>
>> wrote:
>>
>> dear all,
>> thanks for the replay,
>>
>> ./configure: line 5373: icc: command not found
>> configure:5382: $? = 127
>> configure:5371: icc -v >&5
>>
>> I am totally new, What can I do? As I told you if I compile a simple hello
>> program with icc
>> it works.
>>
>> Thanks
>>
>> Diego
>>
>>
>>
>>
>> On 23 November 2012 15:45, Diego Avesani <diego.avesani_at_[hidden]> wrote:
>>>
>>> dear all,
>>> I am new in openMPI world and in general in parallelization. I have some
>>> problem with configuration of openMPI in my laptop.
>>> I have read your FAQ and I tried to google the problem but I was not able
>>> to solve it.
>>> The problem is:
>>>
>>> I have downloaded the openmpi-1.6.3, unpacked it
>>> Then I have installed on my pc intel icc and icpc.
>>> when I run:
>>> ./configure CC=icc CXX=icpc F77=ifort FC=ifort
>>>
>>> I get:
>>>
>>> *** Startup tests
>>> checking build system type... x86_64-unknown-linux-gnu
>>> checking host system type... x86_64-unknown-linux-gnu
>>> checking target system type... x86_64-unknown-linux-gnu
>>> checking for gcc... icc
>>> checking whether the C compiler works... no
>>> configure: error: in `/home/diedro/Downloads/openmpi-1.6.3':
>>> configure: error: C compiler cannot create executables
>>> See `config.log' for more details
>>> diedro_at_diedro-Latitude-E6420:~/Desktop/Downloads/openmpi-1.6.3$
>>>
>>> I do no understand why. I did a simple hello project with icc and it
>>> works.
>>> (in attachment you can fiend the config.log)
>>>
>>> Really thanks for any help.
>>>
>>>
>>> Diego
>>>
>>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users