Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] What is the default install library for PATH and LD_LIBRARY_PATH
From: huaibao zhang (huaibao.zhang_at_[hidden])
Date: 2012-11-13 13:26:31


Hi Reuti,

Thanks for your answer. I really appreciate it.
I am using an old version 1.4.3. for my code. If I only type $./configure, it will compile, but I have no idea where it is installed. I typed $ find /lib -name "libopen-pal.so.0", but it shows nothing. Do you thinks it is caused since I am not a root user or the old version.

Thanks,
Paul

--
Huaibao (Paul) Zhang
Gas Surface Interactions Lab
Department of Mechanical Engineering
University of Kentucky,
Lexington, KY, 40506-0503
Office: 216 Ralph G. Anderson Building
Web:gsil.engineering.uky.edu
On Nov 13, 2012, at 12:24 PM, Reuti <reuti_at_[hidden]> wrote:
> Am 13.11.2012 um 15:44 schrieb huaibao zhang:
> 
>> I installed OpenMPI on my Ubuntu 64 bit desktop. At first, I did not specify "prefix", so even I've installed it. I could not find where it is. Since the "PATH" and "LD" have to be given, the mpicc can find the "lib open-pal.so.0" file. 
> 
> You mean "...can't find..."? If you use the default location, it should have the correct settings already even without adding any path to PATH or LD_LIBRARY_PATH.
> 
> You can use:
> 
> $ find /lib -name "libopen-pal.so.0"
> 
> to spot the location. But I wonder about the version. The actual one seems to be libopen-pal.so.4 -> libopen-pal.so.4.0.3 - which version are you using?
> 
> -- Reuti
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users