Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpif90 wrapper is using -pthread as option to ifort, but option is depreciated
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-11-09 13:42:44


We're actually getting this flag from Libtool during configure. :-\

Hopefully they're updating Libtool upstream to account for this.

If Ralph's suggestion doesn't work, you can always edit the wrapper compiler data files to remove -pthread after you "make install".

On Nov 9, 2012, at 1:21 PM, Reuti wrote:

> Am 09.11.2012 um 19:15 schrieb Ralph Castain:
>
>> Try configuring --without-threads
>>
>>
>> On Nov 9, 2012, at 10:05 AM, Craig Tierney <craig.tierney_at_[hidden]> wrote:
>>
>>> I just built OpenMPI 1.6.3 with ifort 12.1.4. When running ifort I am
>>> getting the warning:
>>>
>>> ifort: command line remark #10010: open '-pthread' is depreciated and
>>> will be removed in a future release. See '-help deprecated'.
>
> And here they list:
>
> -pthread use -reentrancy threaded
>
> -- Reuti
>
>
>>> Is -pthread really needed? Is there a configure option to change this
>>> or should have intel not changed from how other compilers work?
>>>
>>> Thanks,
>>> Craig
>>> _______________________________________________
>>> users mailing list
>>> users_at_[hidden]
>>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/