Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] make check fails with OpenMPI 1.6.3 and Intel Compilers
From: J R Jones (j.r.jones_at_[hidden])
Date: 2012-11-01 11:56:48


Hi

I am trying to build OpenMPI 1.6.3 with the Intel compilers, but one of
the tests in make check fails with a segmentation fault. I wondered if
anyone else has come across this and if so, how they got around it?

$ icc --version
icc (ICC) 12.0.4 20110427

I have logged the output of the build process and include it as a
tarball. The interesting part seems to be this, in make.check:

[blue34:26873] Datatype 0x6794570[] size 36000 align 8 id 0 length 6 used 3
true_lb 0 true_ub 39592 (true_extent 39592) lb 0 ub 39592 (extent 39592)
nbElems 4500 loops 2 flags 104 (commited )-c-----GD--[---][---]
    contain OPAL_FLOAT8
--C--------[---][---] OPAL_LOOP 450 times the next 2 elements extent 88
--C---P-D--[---][---] OPAL_FLOAT8 count 10 disp 0x0 (0) extent 8
(size 80)
--C--------[---][---] OPAL_END_LOOP prev 2 elements first elem
displacement 0 size of data 80
-------G---[---][---] OPAL_END_LOOP prev 3 elements first elem
displacement 0 size of data 36000
Optimized description
--C--------[---][---] OPAL_LOOP 450 times the next 2 elements extent 88
-cC---P-DB-[---][---] OPAL_UINT1 count 80 disp 0x0 (0) extent 1
(size 80)
--C--------[---][---] OPAL_END_LOOP prev 2 elements first elem
displacement 0 size of data 80
-------G---[---][---] OPAL_END_LOOP prev 3 elements first elem
displacement 0 size of data 36000

/bin/sh: line 5: 26873 Segmentation fault ${dir}$tst
FAIL: opal_datatype_test

Has anyone seen this issue before?

Thanks

Jess