Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Java bindings failed to load required libraries
From: Georg Ruzicka (82ruge1bif_at_[hidden])
Date: 2012-10-31 10:11:42


Hello again.

The fault is still there and I can't locate it.

It seem's the first part of the message came from the file
ompi/mpi/java/c/mpi_MPI.c : NO LT_DLADVISE - CANNOT LOAD LIBOMPI
and the second part from
ompi/mpi/java/java/MPI.java

I run a 'make install' in both directories.
As the result I get a mpi.jar and the libmpi_java libraries installed in
/buildpath/lib
of my open mpi installation.

I also searched for the libompi but can't find anything.
I have a 'libmpi.la' library in my /lib directory but no libompi.

Any ideas?

Thanks Georg

----- Ursprüngliche Mail -----
Betreff: Java bindings failed to load required libraries

Hello.

I installed open mpi and try to run the examples.
I used the developer trunk.
C, C++ and Fortran90 examples compiling and running well.

When i tried to run the compiled Hello.java class
i get this messages:

georg_at_ThinkPad-R61:~/ompi-svn/examples$ mpirun java Hello
[ThinkPad-R61:19720] NO LT_DLADVISE - CANNOT LOAD LIBOMPI
JAVA BINDINGS FAILED TO LOAD REQUIRED LIBRARIES
-------------------------------------------------------
Primary job terminated normally, but 1 process returned
a non-zero exit code.. Per user-direction, the job has been aborted.
-------------------------------------------------------
--------------------------------------------------------------------------
mpirun detected that one or more processes exited with non-zero status, thus causing
the job to be terminated. The first process to do so was:

  Process name: [[43465,1],0]
  Exit code: 1
--------------------------------------------------------------------------

I configure with:
./configure --prefix=/home/georg/ompi-install1 --with-platform=optimized --enable-mpi-java --with-jdk-dir=/opt/jdk1.7.0_09

I work with ubuntu 10.10.

I added to .bashrc:
export PATH=$PATH:/home/georg/tools/installed/bin:/home/georg/ompi-install1/bin:/opt/jdk1.7.0_09/bin:/opt/jdk1.7.0_09
export LD_LIBRARY_PATH=$LB_LIBRARY_PATH:/home/georg/ompi-install1/lib:/home/georg/ompi-install1/lib/openmpi:/home/georg/ompi-install1/lib/pkgconfig

I can compile and run java progs

Did anyone know the fault?

Thanks.