Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] open mpi 1.6 with intel compilers
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-10-27 12:34:16


I believe you're referring to a different thread on this mailing list:

    http://www.open-mpi.org/community/lists/users/2012/10/20552.php

I answered the question about shared memory in that thread, not this one (which is about a run-time error).

On Oct 27, 2012, at 12:24 PM, Mahmood Naderan wrote:

>
> >This looks like you're trying to execute an MPICH2-build MPI executable, not Open MPI.
> No that was a general question. I mean message passing is a model of communication
> versus shared memory programming. So what is the point when openmpi uses shared
> memory model?
>
> Regards,
> Mahmood
>
> From: Jeff Squyres <jsquyres_at_[hidden]>
> To: Open MPI Users <users_at_[hidden]>
> Sent: Saturday, October 27, 2012 6:18 PM
> Subject: Re: [OMPI users] open mpi 1.6 with intel compilers
>
> This looks like you're trying to execute an MPICH2-build MPI executable, not Open MPI.
>
> On Oct 27, 2012, at 11:46 AM, Giuseppe P. wrote:
>
> > Hello!
> >
> > I have built open mpi 1.6 with Intel compilers (2013 versions). Compilation was smooth, however even when I try to execute
> > the simple program hello.c:
> >
> > mpirun -np 4 ./hello_c.x
> > [mpiexec_at_claudio.ukzn] HYDU_create_process (./utils/launch/launch.c:102): execvp error on file /opt/intel/composer_xe_2013.0.079/mpirt/bin/intel64/pmi_proxy (No such file or directory)
> > [mpiexec_at_claudio.ukzn] HYD_pmcd_pmiserv_proxy_init_cb (./pm/pmiserv/pmiserv_cb.c:1177): assert (!closed) failed
> > [mpiexec_at_claudio.ukzn] HYDT_dmxu_poll_wait_for_event (./tools/demux/demux_poll.c:77): callback returned error status
> > [mpiexec_at_claudio.ukzn] HYD_pmci_wait_for_completion (./pm/pmiserv/pmiserv_pmci.c:358): error waiting for event
> > [mpiexec_at_claudio.ukzn] main (./ui/mpich/mpiexec.c:689): process manager error waiting for completion
> >
> > Before that, there was an additional error, since also the file mpivars.sh was not present in /opt/intel/composer_xe_2013.0.079/mpirt/bin/intel64/.
> > Even though I managed to create one and it worked:
> >
> > #!/bin/bash
> >
> > if [ -z "`echo $PATH | grep /usr/local/bin`" ]; then
> > export PATH=/usr/local/bin:$PATH
> > fi
> >
> > if [ -z "`echo $LD_LIBRARY_PATH | grep /usr/local/lib`" ]; then
> > if [ -n "$LD_LIBRARY_PATH" ]; then
> > export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
> > else
> > export LD_LIBRARY_PATH=/usr/local/lib
> > fi
> > fi
> >
> > I do not have any clue about how to generate the file pmi_proxy.
> >
> > Thank you in advance for your help!
> >
> > _______________________________________________
> > users mailing list
> > users_at_[hidden]
> > http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> --
> Jeff Squyres
> jsquyres_at_[hidden]
> For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/