Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Java bindings failed to load required libraries
From: Georg Ruzicka (82ruge1bif_at_[hidden])
Date: 2012-10-25 16:35:53


The tool m4, autoconf and libtool are installed.

----- Ursprüngliche Mail -----
Von: "Ralph Castain" <rhc_at_[hidden]>
An: "Open MPI Users" <users_at_[hidden]>
Gesendet: Donnerstag, 25. Oktober 2012 19:54:32 GMT +01:00 Amsterdam/Berlin/Bern/Rom/Stockholm/Wien
Betreff: Re: [OMPI users] Java bindings failed to load required libraries

I haven't worked with ubuntu in awhile, but I expect you need to install libtool

On Oct 25, 2012, at 10:06 AM, Georg Ruzicka <82ruge1bif_at_[hidden]> wrote:

> Hello.
>
> I installed open mpi and try to run the examples.
> I used the developer trunk.
> C, C++ and Fortran90 examples compiling and running well.
>
> When i tried to run the compiled Hello.java class
> i get this messages:
>
> georg_at_ThinkPad-R61:~/ompi-svn/examples$ mpirun java Hello
> [ThinkPad-R61:19720] NO LT_DLADVISE - CANNOT LOAD LIBOMPI
> JAVA BINDINGS FAILED TO LOAD REQUIRED LIBRARIES
> -------------------------------------------------------
> Primary job terminated normally, but 1 process returned
> a non-zero exit code.. Per user-direction, the job has been aborted.
> -------------------------------------------------------
> --------------------------------------------------------------------------
> mpirun detected that one or more processes exited with non-zero status, thus causing
> the job to be terminated. The first process to do so was:
>
> Process name: [[43465,1],0]
> Exit code: 1
> --------------------------------------------------------------------------
>
>
> I configure with:
> ./configure --prefix=/home/georg/ompi-install1 --with-platform=optimized --enable-mpi-java --with-jdk-dir=/opt/jdk1.7.0_09
>
> I work with ubuntu 10.10.
>
> I added to .bashrc:
> export PATH=$PATH:/home/georg/tools/installed/bin:/home/georg/ompi-install1/bin:/opt/jdk1.7.0_09/bin:/opt/jdk1.7.0_09
> export LD_LIBRARY_PATH=$LB_LIBRARY_PATH:/home/georg/ompi-install1/lib:/home/georg/ompi-install1/lib/openmpi:/home/georg/ompi-install1/lib/pkgconfig
>
> I can compile and run java progs
>
> Did anyone know the fault?
>
> Thanks.
>
>
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users