Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] singleton spawn regression
From: Ralph Castain (rhc_at_[hidden])
Date: 2012-10-17 11:31:23


Can you please check the 1.6.3 release candidate and see if it is there? I suspect that the issue here is that the patch didn't get into the 1.6.2 official release, and the version numbers in the repo didn't immediately get updated - so the nightly build was still labeled as 1.6.2 even after the official release came out.

On Oct 16, 2012, at 10:46 AM, Brian Budge <brian.budge_at_[hidden]> wrote:

> Hi all -
>
> There was a bug in version 1.6.1 that caused singleton spawn not to
> work correctly with multi-machine configurations. I verified that a
> nightly build of 1.6.2 fixed this issue, in particular 1.6.2a1r27234
> works. I just grabbed the 1.6.2 official release, and it appears that
> somehow the fix has been removed.
>
> I am testing with the simple_spawn.c example. Instead of passing
> MPI_INFO_NULL to the spawn call, I create an Info object, and set the
> "add-host" to a comma delimited list of nodes. When I run this in the
> nightly mentioned above, without mpirun, everything works as expected
> (the nodes I list in the "add-host" are in the output text of the
> program). When I run the same code with the released 1.6.2, I get the
> old behavior from 1.6.1 where all slaves run on localhost.
>
> Thanks,
> Brian
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users