Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] [1.6.2] Compilation Error (at vtfilter) with Intel Compiler
From: Christian Krause (kizkizzbangbang_at_[hidden])
Date: 2012-10-12 03:35:46


Thanks for the link - also setting CXX F77 and FC did the trick :)

./configure CC=icc CXX=icpc F77=ifort FC=ifort
--prefix=/usr/local/openmpi/1.6.2_intel_12.0.4 --with-sge
--with-hwloc=/usr/local/hwloc/1.5_intel_12.0.4
--with-openib-libdir=/usr/lib64 --with-udapl-libdir=/usr/lib64

works.

On Thu, Oct 11, 2012 at 8:11 PM, wookietreiber
<kizkizzbangbang_at_[hidden]> wrote:
> Hi,
>
> The error I get I couldn't find in the mails from your link. But I also
> didn't set CXX, F77 and FC. I'll try that tomorrow and we'll see if it
> changes anything.
>
> I find the error I get weird because some file is not found which
> I guess should not occur when switching compilers ...
>
>
> On Thu, Oct 11, 2012 at 01:09:28PM -0400, Gus Correa wrote:
>> Hi Christian
>>
>> Would your problem be similar to the one reported two days ago on
>> this thread? [It also failed to compile vampir trace tools,
>> it also didn't have the Intel C++ compiler specified to configure.]
>>
>> http://www.open-mpi.org/community/lists/users/2012/10/20449.php
>>
>> Have you tried to specify the Intel C++ compiler
>> to the configure script?
>>
>> ./configure CC=icc CXX=icpc ... etc, etc ...
>>
>> I hope this helps,
>> Gus Correa
>>
>>
>>
>> On 10/11/2012 11:00 AM, Christian Krause wrote:
>> >Hi,
>> >
>> >I tried to compile the current OpenMPI 1.6.2 with the Intel Compiler
>> >
>> ># icc --version
>> >icc (ICC) 12.0.4 20110427
>> >
>> >
>> >The error I get is the following (I changed directly in the vtfilter
>> >directory where the error occurs to reduce output for this mail):
>> >
>> ># cd ompi/contrib/vt/vt/tools/vtfilter/
>> ># make
>> >Making all in .
>> >make[1]: Entering directory
>> >`/gpfs0/global/local/src/xxx-mpi/openmpi-1.6.2/ompi/contrib/vt/vt/tools/vtfilter'
>> > CXX vtfilter-vt_filter.o
>> >cc1plus: error: vtfilter-vt_filter.d: No such file or directory
>> >make[1]: *** [vtfilter-vt_filter.o] Error 1
>> >make[1]: Leaving directory
>> >`/gpfs0/global/local/src/xxx-mpi/openmpi-1.6.2/ompi/contrib/vt/vt/tools/vtfilter'
>> >make: *** [all-recursive] Error 1
>> >
>> >
>> >configure options from config.log:
>> >
>> >./configure CC=icc --prefix=/usr/local/openmpi/1.6.2_intel_12.0.4
>> >--with-sge --with-hwloc=/usr/local/hwloc/1.5_intel_12.0.4
>> >--with-openib-libdir=/usr/lib64 --with-udapl-libdir=/usr/lib64
>> >
>> >
>> >I have already built hwloc and pciutils locally using icc. Also I
>> >recently compiled OpenMPI 1.6.2 with gcc 4.7.1 with hwloc and pciutils
>> >too which worked without problems (configure basically the same, i.e.
>> >not setting CC and using different hwloc). That's why I'm assuming the
>> >error is somehow icc's fault ... I'm new to this mailing list and I
>> >already received some mails concerning the Intel Compiler so I figure
>> >there may be others who've experienced this problem?
>> >
>> >
>> >Thanks for any help in advance.
>> >
>> >Regards
>> >Christian
>> >_______________________________________________
>> >users mailing list
>> >users_at_[hidden]
>> >http://www.open-mpi.org/mailman/listinfo.cgi/users
>>
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
> --
>
> Beste Grüße / Best Regards
> Christian Krause aka wookietreiber
>
> -----------------------------------------------------------------------
>
> EGAL WIE DICHT DU BIST, GOETHE WAR DICHTER.