Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Intel 13.0.0 -pthreads warning
From: Jonas Juselius (jonas.juselius_at_[hidden])
Date: 2012-10-10 13:16:30


Hi,

we recently installed the latest compilers from Intel (version 13.0.0),
and compiled openmpi 1.6.2 for those compilers. When compiling using the
mpif90, mpicc and mpicxx commands, the compiler spews out warnings that
the "-pthreads" option is deprecated and that "-reentrant threads"
should be used instead. While this is not a problem per se (yet), it
confuses our users. I tried to fix this, but the settings are configured
quite deep in some autoconf macros, and I decided to leave it for the
time being.

Best regards, Jonas Juselius