Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] Open MPI on Cray XE6 / Gemini
From: Reuti (reuti_at_[hidden])
Date: 2012-10-10 10:46:54


Hi,

Am 10.10.2012 um 14:50 schrieb Christoph Niethammer:

> I just tried to use Open MPI 1.7a1r27416 on a Cray XE6 system. Unfortunately I get the following error when I run a simple HelloWorldMPI program:
>
> $ pirun HelloWorldMPI
> App launch reported: 2 (out of 2) daemons - 0 (out of 32) procs
> ...
> [unset]:_pmi_alps_get_appLayout:pmi_alps_get_apid returned with error: Bad file descriptor
> [nid01766:20603] mca_oob_tcp_init: unable to create IPv4 listen socket: Unable to open a TCP socket for out-of-band communications
> ...
>
>
> The installation was configured with the following command:
>
> ./configure --with-platform=contrib/platform/lanl/cray_xe6/optimized-nopanasas --prefix=$HOME/bin/mpi/openmpi/1.7a1r27416

you are doing it local on the headnode only? It includes --with-alps by the platform file and there is the command `aprun` instead of `mpiexec` in the jobscript on a Cray. Maybe the allocation needs to be granted first.

-- Reuti

> I would be very happy if anybdy has an idea, what I could have missed during installation/runtime.
>
> Thanks in advance.
>
> Best regards
> Christoph
>
>
> --
>
> Christoph Niethammer
> High Performance Computing Center Stuttgart (HLRS)
> Nobelstrasse 19
> 70569 Stuttgart
>
> Tel: ++49(0)711-685-87203
> email: niethammer_at_[hidden]
> http://www.hlrs.de/people/niethammer
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users