Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] question to binding options in openmpi-1.6.2
From: Ralph Castain (rhc_at_[hidden])
Date: 2012-10-03 09:03:50


Okay, I looked at this and the problem isn't in the code. The problem is that the 1.6 series doesn't have the more sophisticated discovery and mapping algorithms of the 1.7 series. In this case, the specific problem is that the 1.6 series doesn't automatically detect the number of sockets on a node - you have to tell it in your hostfile:

foo.domain.org sockets=2 slots=4

Otherwise, you'll get this poor error message as it tries to communicate that 0 sockets => zero processes.

On Oct 2, 2012, at 2:44 AM, Siegmar Gross <Siegmar.Gross_at_[hidden]> wrote:

> Option "-npersocket" doesnt't work, even if I reduce "-npersocket"
> to "1". Why doesn't it find any sockets, although the above commands
> could find both sockets?
>
> mpiexec -report-bindings -host sunpc0 -np 2 -npersocket 1 hostname
> --------------------------------------------------------------------------
> Your job has requested a conflicting number of processes for the
> application:
>
> App: hostname
> number of procs: 2
>
> This is more processes than we can launch under the following
> additional directives and conditions:
>
> number of sockets: 0
> npersocket: 1
>
> Please revise the conflict and try again.
> --------------------------------------------------------------------------