Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] static, standalone mpirun (Jeff Squyres)
From: Ilias Miroslav (Miroslav.Ilias_at_[hidden])
Date: 2012-09-28 08:52:15


Dear Jeff,

here I meant "<space>" simply my local installation space...
> ./configure --prefix=<space> --without-memory-manager CXX=icpc CC=icc F77=ifort FC=ifort LDFLAGS=--static --disable-shared --enable-static

In between I managed to fix the relocated static, standalone mpirun (v 1.6.1): beyond the mpirun exec, the share/openmpi directory a had to copy also the etc/ directory, containing openmpi-default-hostfile and other files.

Wrt to your example, I moving my statically linked mpirun and related directories share+etc to other servers on which I am lauching parallel jobs.

Regards, Miro

----------------------------------------------------------------------

Message: 1
Date: Tue, 25 Sep 2012 17:22:49 +0200
From: Jeff Squyres <jsquyres_at_[hidden]>
Subject: Re: [OMPI users] static, standalone mpirun
To: Open MPI Users <users_at_[hidden]>
Message-ID: <88887FBA-18BC-4DDE-8451-79960762F611_at_[hidden]>
Content-Type: text/plain; charset=us-ascii

Sorry for jumping in late in this thread. More below.

On Sep 20, 2012, at 1:43 PM, Ilias Miroslav wrote:

> I prepared my own static OpenMPI files (mpirun, mpif90...) within openmpi-1.6.1.tar.gz
>
> ./configure --prefix=<space> --without-memory-manager CXX=icpc CC=icc F77=ifort FC=ifort LDFLAGS=--static --disable-shared --enable-static

What is the exact value of "<space>" that you are putting in? Are you actually putting in a space (i.e., " ")? That does not work for me -- configure errors out because the prefix was not an absolute path.

More specifically, can you detail the exact commands you used to configure, build, install, relocate, and then try to run the relocated Open MPI?

For example, I am able to do the following:

-----
% ./configure --prefix=/home/jsquyres/bogus --disable-mpi-fortran --disable-vt --disable-mpi-cxx --disable-mpi-io --enable-mpirun-prefix-by-default --disable-shared --enable-static
<...lots of output snipped...>
% make install > /dev/null
% cat <<EOF >> /home/jsquyres/bogus/etc/openmpi-default-hostfile
? svbu-mpi027
? svbu-mpi029
? EOF
% mpirun -np 2 hostname
svbu-mpi027
svbu-mpi029
% mv /home/jsquyres/bogus /home/jsquyres/bogus2
% setenv OPAL_PREFIX /home/jsquyres/bogus2
% set path = (/home/jsquyres/bogus2/bin $path)
% mpirun -np 2 hostname
svbu-mpi027
svbu-mpi029
%
-----

And it seems to work for me.

Are you doing something different?

--
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/
------------------------------
_______________________________________________
users mailing list
users_at_[hidden]
http://www.open-mpi.org/mailman/listinfo.cgi/users
End of users Digest, Vol 2364, Issue 4
**************************************