Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] static, standalone mpirun
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-09-25 11:22:49


Sorry for jumping in late in this thread. More below.

On Sep 20, 2012, at 1:43 PM, Ilias Miroslav wrote:

> I prepared my own static OpenMPI files (mpirun, mpif90...) within openmpi-1.6.1.tar.gz
>
> ./configure --prefix=<space> --without-memory-manager CXX=icpc CC=icc F77=ifort FC=ifort LDFLAGS=--static --disable-shared --enable-static

What is the exact value of "<space>" that you are putting in? Are you actually putting in a space (i.e., " ")? That does not work for me -- configure errors out because the prefix was not an absolute path.

More specifically, can you detail the exact commands you used to configure, build, install, relocate, and then try to run the relocated Open MPI?

For example, I am able to do the following:

-----
% ./configure --prefix=/home/jsquyres/bogus --disable-mpi-fortran --disable-vt --disable-mpi-cxx --disable-mpi-io --enable-mpirun-prefix-by-default --disable-shared --enable-static
<...lots of output snipped...>
% make install > /dev/null
% cat <<EOF >> /home/jsquyres/bogus/etc/openmpi-default-hostfile
? svbu-mpi027
? svbu-mpi029
? EOF
% mpirun -np 2 hostname
svbu-mpi027
svbu-mpi029
% mv /home/jsquyres/bogus /home/jsquyres/bogus2
% setenv OPAL_PREFIX /home/jsquyres/bogus2
% set path = (/home/jsquyres/bogus2/bin $path)
% mpirun -np 2 hostname
svbu-mpi027
svbu-mpi029
%
-----

And it seems to work for me.

Are you doing something different?

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/