Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: [OMPI users] bindings not reported in openmpi-1.9a1r27359
From: Siegmar Gross (Siegmar.Gross_at_[hidden])
Date: 2012-09-23 06:32:35


Hi,

yesterday I installed openmpi-1.9a1r27359 and it doesn't report process
bindings on Solaris 10 x86_64 and Linux x86_64. As I showed in my previous
email for openmpi-1.7, it worked for openmpi-1.6.2.

tyr fd1026 114 mpiexec -np 2 -host sunpc0 -report-bindings \
  -map-by core -bind-to core date
Sun Sep 23 12:29:25 CEST 2012
Sun Sep 23 12:29:25 CEST 2012

tyr fd1026 115 mpiexec -np 2 -host linpc0 -report-bindings \
  -map-by core -bind-to core date
--------------------------------------------------------------------------
WARNING: a request was made to bind a process. While the system
supports binding the process itself, at least one node does NOT
support binding memory to the process location.

  Node: linpc0

This is a warning only; your job will continue, though performance may
be degraded.
--------------------------------------------------------------------------
Sun Sep 23 12:29:36 CEST 2012
Sun Sep 23 12:29:36 CEST 2012

tyr fd1026 116 mpiexec -np 2 -host tyr -report-bindings \
  -map-by core -bind-to core date
[tyr.informatik.hs-fulda.de:24039] MCW rank 0 bound to socket 0[core 0[hwt 0]]: [B][.]
[tyr.informatik.hs-fulda.de:24039] MCW rank 1 bound to socket 1[core 1[hwt 0]]: [.][B]
Sun Sep 23 12:29:48 CEST 2012
Sun Sep 23 12:29:48 CEST 2012

Kind regards

Siegmar