Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] static, standalone mpirun
From: Ilias Miroslav (Miroslav.Ilias_at_[hidden])
Date: 2012-09-23 02:11:20


Hello,

> Is the path correct for the new location?

yes, the $PATH points to the location of the sole static "mpirun" and of the share/openmpi/*.txt directory.

Why is mpirun constructing $<PATH_OF_MPIRUN>/etc/openmpi-default-hostfile as I see in the error message below ?
( /home/ilias/work/dirac/build_Intel_OpenMPI_MKL_ILP64_STATIC/etc/openmpi-default-hostfile )

> > Check to make sure the path and filename are correct.
Please what others variables/files do I have to set/copy with the static mpirun ?
 I am setting (experience from previous OpenMPI versions) OPAL_PREFIX, which is location of my static mpirun.

The wish is to distribute own static mpirun with related necessary files to other servers to be able to launch static parallel applications there.

Thanks, Miro

On Sep 20, 2012, at 5:15 AM, Ilias Miroslav <Miroslav.Ilias_at_[hidden]> wrote:
> Hi again,
>
> as I checked the mailing list - isn't it this bug showing up again in static version ?
>
> http://www.open-mpi.org/community/lists/users/2012/05/19278.php
>
> M
> ________________________________________
> From: Ilias Miroslav
> Sent: Thursday, September 20, 2012 1:43 PM
> To: users_at_[hidden]
> Subject: static, standalone mpirun
>
> Greetings,
>
> I prepared my own static OpenMPI files (mpirun, mpif90...) within openmpi-1.6.1.tar.gz
>
> ./configure --prefix=<space> --without-memory-manager CXX=icpc CC=icc F77=ifort FC=ifort LDFLAGS=--static --disable-shared --enable-static
>
> and I was trying to launch parallel job at other machine (I specified the OPAL_PREFIX variable and also copied share/openmi directory there).
>
> However, I got this error - please what am I missing ? Thanks, Miro
>
> ./mpirun --np 1 dirac.x
> --------------------------------------------------------------------------
> Open RTE was unable to open the hostfile:
> /home/ilias/work/dirac/build_Intel_OpenMPI_MKL_ILP64_STATIC/etc/openmpi-default-hostfile
> Check to make sure the path and filename are correct.
> --------------------------------------------------------------------------
> [sparc:23537] [[29526,0],0] ORTE_ERROR_LOG: Not found in file base/ras_base_allocate.c at line 200
> [sparc:23537] [[29526,0],0] ORTE_ERROR_LOG: Not found in file base/plm_base_launch_support.c at line 99
> [sparc:23537] [[29526,0],0] ORTE_ERROR_LOG: Not found in file plm_rsh_module.c at line 1167
>