Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] error compiling openmpi-1.6.1 on Windows 7
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-09-10 15:18:11


We've added "lo" back into the list, but I'm curious as to why 127.0.0.1/8 doesn't work.

If you run ipconfig, what does it say for the localhost entry? I.e., what's its IP address and netmask?

On Sep 9, 2012, at 1:27 PM, Siegmar Gross wrote:

> Hi Shiqing,
>
> I disabled IPv6 in my network adpaters and activated the entry
> "127.0.0.1 localhost" in file c:\Windows\System32\drivers\etc\hosts
> to overwrite the IPv6 address for localhost in the registry.
>
>
> "ping localhost" displays the following output.
>
> Ping wird ausgeführt für hermes [127.0.0.1] mit 32 Bytes Daten:
> Antwort von 127.0.0.1: Bytes=32 Zeit<1ms TTL=128
> ...
>
>
> Nevertheless I get the warning from "mpiexec" before the output of
> my program.
>
> c:\...>mpiexec init_finalize.exe
> --------------------------------------------------------------------------
> WARNING: An invalid value was given for btl_tcp_if_exclude. This
> value will be ignored.
>
> Local host: hermes
> Value: 127.0.0.1/8
> Message: Did not find interface matching this subnet
> --------------------------------------------------------------------------
>
> Hello!
>
>
>
> I can avoid the warning with the following command line.
>
> c:\...>mpiexec -mca btl_tcp_if_exclude lo init_finalize.exe
>
> Hello!
>
>
>
> c:\...>ompi_info --param btl tcp | \cygwin\bin\grep if_exclude
> Comma-delimited list of devices or CIDR notation of networks to use
> for MPI communication (e.g., "eth0,eth1" or
> "192.168.0.0/16,10.1.4.0/24"). Mutually exclusive with
> btl_tcp_if_exclude.
> MCA btl: parameter "btl_tcp_if_exclude" (current value:
> <127.0.0.1/8,sppp>, data source: default value)
>
> Perhaps it is necessary to add "lo" once more to the list to make
> Windows 7 happy.
>
>
> Kind regards
>
> Siegmar
>
>
>>> The warning message is because the loopback adapter is excluded by
>>> default, but this adapter is actually not installed on Windows.
>>>
>>> One solution might be installing the loopback adapter on Windows. It
>>> very easy, only a few minutes.
>>
>> I have installed the loopback adapter but it has the wrong IP address
>> so that I still have the same warning message.
>>
>>
>> Ethernet-Adapter LAN-Verbindung 3:
>>
>> Verbindungsspezifisches DNS-Suffix:
>> Beschreibung. . . . . . . . . . . : Microsoft Loopbackadapter
>> Physikalische Adresse . . . . . . : 02-00-4C-4F-4F-50
>> DHCP aktiviert. . . . . . . . . . : Ja
>> Autokonfiguration aktiviert . . . : Ja
>> Verbindungslokale IPv6-Adresse . : fe80::25d7:866d:f5c9:7295%31(Bevorzugt)
>> IPv4-Adresse (Auto. Konfiguration): 169.254.114.149(Bevorzugt)
>> Subnetzmaske . . . . . . . . . . : 255.255.0.0
>> Standardgateway . . . . . . . . . :
>> DHCPv6-IAID . . . . . . . . . . . : 671219788
>> DHCPv6-Client-DUID. . . . . . . . :
> 00-01-00-01-15-A4-69-BD-C0-F8-DA-35-64-02
>> DNS-Server . . . . . . . . . . . : fec0:0:0:ffff::1%1
>> fec0:0:0:ffff::2%1
>> fec0:0:0:ffff::3%1
>> NetBIOS über TCP/IP . . . . . . . : Aktiviert
>>
>>
>> I tried to change the address to 127.0.0.1 without luck. When I switch
>> from "automatic" to "manual" in the properties menue and start the
>> IP address with 127 a window pops up announcing that an IP address
>> starting with 127 is reserved for the loopback adapter so that I couldn't
>> change the address. How did you manage to get the loopback adapter address
>> 127.0.0.1 or do you live with the message from Open MPI? Thank you very
>> much for a short answer in advance.
>>
>>
>> Kind regards
>>
>> Siegmar
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users

-- 
Jeff Squyres
jsquyres_at_[hidden]
For corporate legal information go to: http://www.cisco.com/web/about/doing_business/legal/cri/