Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] error compiling openmpi-1.6.1 on Windows 7
From: Shiqing Fan (fan_at_[hidden])
Date: 2012-09-06 10:58:03


Hi Siegmar,

Glad to hear that it's working for you.

The warning message is because the loopback adapter is excluded by
default, but this adapter is actually not installed on Windows.

One solution might be installing the loopback adapter on Windows. It
very easy, only a few minutes.

Or it may be possible to avoid this message from internal Open MPI. But
I'm not sure about how this can be done.

Regards,
Shiqing

On 2012-09-06 7:48 AM, Siegmar Gross wrote:
> Hi Shiqing,
>
> I have solved the problem with the double quotes in OPENMPI_HOME but
> there is still something wrong.
>
> set OPENMPI_HOME="c:\Program Files (x86)\openmpi-1.6.1"
>
> mpicc init_finalize.c
> Cannot open configuration file "c:\Program Files (x86)\openmpi-1.6.1"/share/openmpi\mpicc-wrapper-data.txt
> Error parsing data file mpicc: Not found
>
>
> Everything is OK if you remove the double quotes which Windows
> automatically adds.
>
> set OPENMPI_HOME=c:\Program Files (x86)\openmpi-1.6.1
>
> mpicc init_finalize.c
> Microsoft (R) 32-Bit C/C++-Optimierungscompiler Version 16.00.40219.01 für 80x86
> ...
>
> mpiexec init_finalize.exe
> --------------------------------------------------------------------------
> WARNING: An invalid value was given for btl_tcp_if_exclude. This
> value will be ignored.
>
> Local host: hermes
> Value: 127.0.0.1/8
> Message: Did not find interface matching this subnet
> --------------------------------------------------------------------------
>
> Hello!
>
>
> I get the output from my program but also a warning from Open MPI.
> The new value for the loopback device was introduced a short time
> ago when I have had problems with the loopback device on Solaris
> (it used "lo0" instead of your default "lo"). How can I avoid this
> message? The 64-bit version of my program still hangs.
>
>
> Kind regards
>
> Siegmar
>
>
>>> Could you try set OPENMPI_HOME env var to the root of the Open MPI dir?
>>> This env is a backup option for the registry.
>> It solves one problem but there is a new problem now :-((
>>
>>
>> Without OPENMPI_HOME: Wrong pathname to help files.
>>
>> D:\...\prog\mpi\small_prog>mpiexec init_finalize.exe
>> --------------------------------------------------------------------------
>> Sorry! You were supposed to get help about:
>> invalid if_inexclude
>> But I couldn't open the help file:
>> D:\...\prog\mpi\small_prog\..\share\openmpi\help-mpi-btl-tcp.txt:
>> No such file or directory. Sorry!
>> --------------------------------------------------------------------------
>> ...
>>
>>
>>
>> With OPENMPI_HOME: It nearly uses the correct directory. Unfortunately
>> the pathname contains the character " in the wrong place so that it
>> couldn't find the available help file.
>>
>> set OPENMPI_HOME="c:\Program Files (x86)\openmpi-1.6.1"
>>
>> D:\...\prog\mpi\small_prog>mpiexec init_finalize.exe
>> --------------------------------------------------------------------------
>> Sorry! You were supposed to get help about:
>> no-hostfile
>> But I couldn't open the help file:
>> "c:\Program Files (x86)\openmpi-1.6.1"\share\openmpi\help-hostfile.txt: Invalid argument. Sorry
>> !
>> --------------------------------------------------------------------------
>> [hermes:04964] [[12187,0],0] ORTE_ERROR_LOG: Not found in file ..\..\openmpi-1.6.1\orte\mca\ras\base
>> \ras_base_allocate.c at line 200
>> [hermes:04964] [[12187,0],0] ORTE_ERROR_LOG: Not found in file ..\..\openmpi-1.6.1\orte\mca\plm\base
>> \plm_base_launch_support.c at line 99
>> [hermes:04964] [[12187,0],0] ORTE_ERROR_LOG: Not found in file ..\..\openmpi-1.6.1\orte\mca\plm\proc
>> ess\plm_process_module.c at line 996
>>
>>
>>
>> It looks like that the environment variable can also solve my
>> problem in the 64-bit environment.
>>
>> D:\g...\prog\mpi\small_prog>mpicc init_finalize.c
>>
>> Microsoft (R) C/C++-Optimierungscompiler Version 16.00.40219.01 für x64
>> ...
>>
>>
>> The process hangs without OPENMPI_HOME.
>>
>> D:\...\prog\mpi\small_prog>mpiexec init_finalize.exe
>> ^C
>>
>>
>> With OPENMPI_HOME:
>>
>> set OPENMPI_HOME="c:\Program Files\openmpi-1.6.1"
>>
>> D:\...\prog\mpi\small_prog>mpiexec init_finalize.exe
>> --------------------------------------------------------------------------
>> Sorry! You were supposed to get help about:
>> no-hostfile
>> But I couldn't open the help file:
>> "c:\Program Files\openmpi-1.6.1"\share\openmpi\help-hostfile.txt: Invalid argument. S
>> orry!
>> --------------------------------------------------------------------------
>> [hermes:05248] [[10367,0],0] ORTE_ERROR_LOG: Not found in file ..\..\openmpi-1.6.1\orte\mc
>> a\ras\base\ras_base_allocate.c at line 200
>> [hermes:05248] [[10367,0],0] ORTE_ERROR_LOG: Not found in file ..\..\openmpi-1.6.1\orte\mc
>> a\plm\base\plm_base_launch_support.c at line 99
>> [hermes:05248] [[10367,0],0] ORTE_ERROR_LOG: Not found in file ..\..\openmpi-1.6.1\orte\mc
>> a\plm\process\plm_process_module.c at line 996
>>
>>
>> At least the program doesn't block any longer. Do you have any ideas
>> how this new problem can be solved?
>>
>>
>> Kind regards
>>
>> Siegmar
>>
>>
>>
>>> On 2012-09-05 1:02 PM, Siegmar Gross wrote:
>>>> Hi Shiqing,
>>>>
>>>>>>> D:\...\prog\mpi\small_prog>mpiexec init_finalize.exe
>>>>>>> ---------------------------------------------------------------------
>>>>>>> Sorry! You were supposed to get help about:
>>>>>>> invalid if_inexclude
>>>>>>> But I couldn't open the help file:
>>>>>>> D:\...\prog\mpi\small_prog\..\share\openmpi\help-mpi-btl-tcp.txt:
>>>>>>> No such file or directory. Sorry!
>>>>>>> ---------------------------------------------------------------------
>>>>>> ...
>>>>>>> Why does "mpiexec" look for the help file relativ to my current
>>>>>>> program and not relative to itself? The file is part of the
>>>>>>> package.
>>>>>> Do you know how I can solve this problem?
>>>>> I have similar issue with message from tcp, but it's not finding the
>>>>> file, it's something else, which doesn't affect the execution of the
>>>>> application. Could you make sure the help-mpi-btl-tcp.txt is actually in
>>>>> the path D:\...\prog\mpi\small_prog\..\share\openmpi\?
>>>> That wouldn't be a good idea because I have MPI programs in different
>>>> directories so that I would have to install all help files in several
>>>> places (<my_directory>/../share/openmpi/help*.txt). All help files are
>>>> available in the installation directory of Open MPI.
>>>>
>>>> dir "c:\Program Files (x86)\openmpi-1.6.1\bin\mpiexec.exe"
>>>> ...
>>>> 29.08.2012 10:59 38.912 mpiexec.exe
>>>> ...
>>>> dir "c:\Program Files (x86)\openmpi-1.6.1\bin\..\share\openmpi\help-mpi-btl-tcp.txt"
>>>> ...
>>>> 03.04.2012 16:30 631 help-mpi-btl-tcp.txt
>>>> ...
>>>>
>>>> I don't know if "mpiexec" or my program "init_finilize" is responsible
>>>> for the error message but whoever is responsible shouldn't use the path
>>>> to my program but the prefix_dir from MPI to find the help files. Perhaps
>>>> you can change the behaviour in the Open MPI source code.
>>>>
>>>>
>>>>>>> I can also compile in 64-bit mode but the program hangs.
>>>>>> Do you have any ideas why the program hangs? Thank you very much for any
>>>>>> help in advance.
>>>>> To be honest I don't know. I couldn't reproduce it. Did you try
>>>>> installing the binary installer, will it also behave the same?
>>>> I like to have different versions of Open MPI which I activate via
>>>> a batch file so that I can still run my program in an old version if
>>>> something goes wrong in a new one. I have no entries in the system
>>>> environment or registry so that I can even run different versions in
>>>> different command windows without problems (everything is only known
>>>> within the command window in which a have run my batch file). It seems
>>>> that you put something in the registry when I use your installer.
>>>> Perhaps you remember an earlier email where I had to uninstall an old
>>>> version because the environment in my own installation was wrong
>>>> as long as your installation was active. Nevertheless I can give it
>>>> a try. Perhaps I find out if you set more than just the path to your
>>>> binaries. Do you know if there is something similar to "truss" or
>>>> "strace" in the UNIX world so that I can see where the program hangs?
>>>> Thank you very much for your help in advance.
>>>>
>>>>
>>>> Kind regards
>>>>
>>>> Siegmar
>>>>
>>>
>>> --
>>> ---------------------------------------------------------------
>>> Shiqing Fan
>>> High Performance Computing Center Stuttgart (HLRS)
>>> Tel: ++49(0)711-685-87234 Nobelstrasse 19
>>> Fax: ++49(0)711-685-65832 70569 Stuttgart
>>> http://www.hlrs.de/organization/people/shiqing-fan/
>>> email: fan_at_[hidden]
>>>
>>
>

-- 
---------------------------------------------------------------
Shiqing Fan
High Performance Computing Center Stuttgart (HLRS)
Tel: ++49(0)711-685-87234      Nobelstrasse 19
Fax: ++49(0)711-685-65832      70569 Stuttgart
http://www.hlrs.de/organization/people/shiqing-fan/
email: fan_at_[hidden]