Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |  

This web mail archive is frozen.

This page is part of a frozen web archive of this mailing list.

You can still navigate around this archive, but know that no new mails have been added to it since July of 2016.

Click here to be taken to the new web archives of this list; it includes all the mails that are in this frozen archive plus all new mails that have been sent to the list since it was migrated to the new archives.

Subject: Re: [OMPI users] -hostfile ignored in 1.6.1 / SGE integration broken
From: Reuti (reuti_at_[hidden])
Date: 2012-09-03 17:40:13


Hi Ralph,

Am 03.09.2012 um 23:34 schrieb Ralph Castain:

>
> On Sep 3, 2012, at 2:12 PM, Reuti <reuti_at_[hidden]> wrote:
>
>> Hi all,
>>
>> I just compiled Open MPI 1.6.1 and before digging any deeper: does anyone else notice, that the command:
>>
>> $ mpiexec -n 4 -machinefile mymachines ./mpihello
>>
>> will ignore the argument "-machinefile mymachines" and use the file "openmpi-default-hostfile" instead all the time?
>
> Try setting "-mca orte_default_hostfile mymachines" instead.

Is this a known bug and will be fixed or is this the new syntax?

>> ==
>>
>> SGE issue
>>
>> I usually don't install new versions instantly, so I only noticed right now, that in 1.4.5 I get a wrong allocation inside SGE (always one process less than requested with `qsub -pe orted N ...`. This I tried only, as with 1.6.1 I get:
>>
>> --------------------------------------------------------------------------
>> There are no nodes allocated to this job.
>> --------------------------------------------------------------------------
>>
>> all the time.
>
> Weird - I'm not sure I understand what you are saying. Is this happening with 1.6.1 as well? Or just with 1.4.5?

1.6.1 = no nodes allocated
1.4.5 = one process less than requested
1.4.1 = works as it should

-- Reuti

>
>>
>> ==
>>
>> I configured with:
>>
>> ./configure --prefix=$HOME/local/... --enable-static --disable-shared --with-sge
>>
>> and adjusted my PATHs accordingly (at least: I hope so).
>>
>> -- Reuti
>> _______________________________________________
>> users mailing list
>> users_at_[hidden]
>> http://www.open-mpi.org/mailman/listinfo.cgi/users
>
>
> _______________________________________________
> users mailing list
> users_at_[hidden]
> http://www.open-mpi.org/mailman/listinfo.cgi/users