Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] -hostfile ignored in 1.6.1 / SGE integration broken
From: Reuti (reuti_at_[hidden])
Date: 2012-09-03 17:12:14


Hi all,

I just compiled Open MPI 1.6.1 and before digging any deeper: does anyone else notice, that the command:

$ mpiexec -n 4 -machinefile mymachines ./mpihello

will ignore the argument "-machinefile mymachines" and use the file "openmpi-default-hostfile" instead all the time?

==

SGE issue

I usually don't install new versions instantly, so I only noticed right now, that in 1.4.5 I get a wrong allocation inside SGE (always one process less than requested with `qsub -pe orted N ...`. This I tried only, as with 1.6.1 I get:

--------------------------------------------------------------------------
There are no nodes allocated to this job.
--------------------------------------------------------------------------

all the time.

==

I configured with:

./configure --prefix=$HOME/local/... --enable-static --disable-shared --with-sge

and adjusted my PATHs accordingly (at least: I hope so).

-- Reuti